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Chapter 1

Introduction

Raritan Multi-Platform Client (MPC), Raritan Remote Client (RRC), and
the Virtual KVM Client (VKC) are graphical user interfaces for the Raritan
Dominion and IP-Reach product lines, providing remote access to target
servers connected to Raritan KVM over IP devices.

By default, generation 2 Raritan devices use VKC. However, generation
2 devices will not work using RRC. Non-Windows users must use
Raritan Multi-Platform Client and Windows® users connecting to a
generation 1 Raritan device must use RRC.

The standalone Raritan Serial Console (RSC) is used to make direct
connections to a serial target without going through the device. The user
specifies the device address and the port number (target), and is then
connected.

In This Chapter

Use With RaANtaN PrOOUCES .....covveieiieee et e e e e v eeeeenaeeees 1
KVM and Serial Access Client USer GUIAE ........oooeveeeeeeeiiiiiiieeeiee e 2

Use with Raritan Products

m
i

Raritan.

The following table lists Raritan products and the client applications with
which they work:

Product Works with...

<
T
@)
Y
Py,
@)
<
X
@)

KX1Gl
KX 1l G2

KX 11-101

KSX G1

v
v
KX101Gl
v’
v

KSX 1l G2
SX

IP Reach
G1

UST-IP G1

N
BN
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Legend:
G1 Generation 1
G2 Generation 2

Note: There are some differences in MPC when used with the Dominion
KX I, Dominion KX Il, and Dominion KSX Il devices; these differences
are noted in the user guide.

KVM and Serial Access Client User Guide

This user guide provides information on using Raritan's KVM and serial
clients. A PDF version of the user guide can be downloaded from
Raritan's Firmware and Documentation page on the Raritan website (see
www.raritan.com). Raritan recommends that you refer to the Raritan
website for the most up-to-date user guides available.

=i=Raritan.



Chapter 2

Virtual KVM Client (VKC)

In This Chapter

OVEBIVIBW ...ttt ettt 3
VKC Toolbar and ShortCut KEYS .........cuvieiiiiiieiiiiieeiiiee e 3
CONNECHION PrOPEITIES ...ttt 6
ConNection INFOMMALION .......coiiiiiiiiiiii e 8
Keyboard OPLIONS .......cia ittt e e 8
VidEO PrOPEITIES ..cceiieiiiieee e 13
MOUSE OPLIONS ...eeieeiieieeee ittt e e e e et e e e e e e e e snebe e e e e e e e e e annes 17
TOOI OPLIONS ..ottt e e e e e anees 22
VIEBW OPLIONS .ottt et e et e e e abaee e e anees 24
(=TT oI @] o] (0] oIS PRSPPSO 25

Overview

Whenever you access a target server using the Remote Console, a
Virtual KVM Client (VKC) window opens. There is one Virtual KVM Client
for each target server connected. These windows can be accessed via
the Windows task bar.

Virtual KVM Client windows can be minimized, maximized, and moved
around your computer desktop.

Note: Refreshing your HTML browser will close the Virtual KVM Client
connection, so exercise caution.

Note: If you are using FireFox 3.0.3, you may experience problems
launching the application. If this occurs, clear the browser cache and
launch the application again.

VKC Toolbar and Shortcut Keys

Button Button

i

Name

Connection
Properties

Raritan.

Description

Opens the Modify Connection Properties
dialog from which you can manually adjust
bandwidth options (such as connection
speed, color depth, and so forth).

Same as choosing Connection >
Properties or choosing Connection
Properties on the shortcut menu, which is
opened by pressing Ctrl+Left Alt+M.
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Button Button
Name

% Video
Settings

Color
‘E' Calibration
& Target
Screenshot

Synchronize
Mouse

&

ﬁ Refresh
Screen

k=== Auto-sense

the s Video
Settings
Send
Ctrl+Alt+Del

Description

Opens the Video Settings dialog, allowing
you to manually adjust video conversion
parameters.

Same as choosing Video > Video Settings
or choosing Video Settings on the shortcut
menu, which is opened by pressing
Ctrl+Left Alt+M.

Adjusts color settings to reduce excess
color noise.

Same as choosing Video > Color Calibrate.

Click to take a screenshot of the target
server and save it to a file of your
choosing.

In dual-mouse mode, forces realignment of
the target server mouse pointer with the
mouse pointer.

Same as choosing Mouse > Synchronize
Mouse or choosing Synchronize Mouse on
the shortcut menu, which is opened by
pressing Ctrl+Left Alt+M.

Forces a refresh of the video screen.

Same as choosing Video > Refresh Screen
or choosing Refresh Screen on the
shortcut menu, which is opened by
pressing Ctrl+Left Alt+M.

Forces a refresh of the video settings
(resolution, refresh rate).

Same as choosing Video > Auto-sense
Video Settings.

Sends a Ctrl+Alt+Del hot key combination
to the target server.

Same as choosing Keyboard > Send
Ctrl+Alt+Del.

=i=Raritan.



Button Button

2

Name

Single Cursor
Mode

j:E Full Screen
Mode

‘E Scaling

i

Raritan.

Description

Starts Single Cursor mode in which the
local mouse pointer no longer appears
onscreen.

Same as choosing Mouse > Single Cursor
Mode. Press Ctrl+Alt+X to exit this mode.
Alternatively, choose Single/Double Cursor
from the shortcut menu, which is opened
by pressing Ctrl+Left Alt+M.

Maximizes the screen real estate to view
the target server desktop.

Same as choosing View > Target Screen
Resolution (in MPC) or Full Screen (in
RRC). Alternatively, press Ctrl+Left Alt+M
to open the shortcut menu and then
choose Full/Normal Screen or press the F
key on your keyboard.

Increases or reduces the target video size
S0 you can view the entire contents of the
target server window without using the
scroll bar.

Chapter 2: Virtual KVM Client (VKC)
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Connection Properties

The dynamic video compression algorithms maintain KVM console
usability under varying bandwidth constraints. The devices optimize
KVM output not only for LAN use, but also for WAN use. These devices
can also control color depth and limit video output, offering an optimal
balance between video quality and system responsiveness for any
bandwidth.

The parameters in the Properties dialog can be optimized to suit your
needs for different operating environments.

> To set the connection properties:
1. Choose Connection > Properties or click the Connection Properties

button E in the toolbar. The Properties dialog appears.

Properties E

Connection Speed -1 3 Ethernet

Color Depth (15-hitRGB Calor v |

Smoothing < | > Loy

Ok | Cancel | |

Note: KX 1I-101 does not support 1G Ethernet.

2. Choose the Connection Speed from the drop-down list. The device
can automatically detect available bandwidth and not limit bandwidth
use. However, you can also adjust this usage according to
bandwidth limitations.

= Auto

= 1G Ethernet

= 100 Mb Ethernet

= 10 Mb Ethernet

* 1.5 Mb (MAX DSL/T1)

= 1 Mb (Fast DSL/T1)

» 512 Kb (Medium DSL/T1)
= 384 Kb (Slow DSL/T1)

=i=Raritan.
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= 256 Kb (Cable)

= 128 Kb (Dual ISDN)
= 56 kb (ISP Modem)

= 33 kb (Fast Modem)
= 24 kb (Slow Modem)

Note that these settings are an optimization for specific conditions
rather than an exact speed. The client and server always attempt to
deliver video as quickly as possible on the network regardless of the
current network speed and encoding setting. But the system will be
most responsive when the settings match the real world environment.

Choose the Color Depth from the drop-down list. The device can
dynamically adapt the color depth transmitted to remote users in
order to maximize usability in all bandwidths.

= 15-bit RGB Color
= 8-bit RGB Color

= 4-bit Color
= 4-bit Gray
= 3-bit Gray
= 2-bit Gray

= Black and White

Important: For most administrative tasks (server monitoring,
reconfiguring, and so on), the full 24-bit or 32-bit color spectrum
made available by most modern video graphics cards is not
necessary. Attempting to transmit such high color depths wastes
network bandwidth.

Use the slider to select the desired level of Smoothing (15-bit color
mode only). The level of smoothing determines how aggressively to
blend screen regions with small color variation into a single smooth
color. Smoothing improves the appearance of target video by
reducing displayed video noise.

Click OK to set these properties.
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Connection Information

To obtain information about your Virtual KVM Client
connection:

Choose Connection > Connection Info. The Connection Info window
opens.

The following information is displayed about the current connection:

Device Name - The name of the device.
IP Address - The IP address of the device.

Port - The KVM communication TCP/IP port used to access the
target device.

Data In/Second - Data rate in.

Data Out/Second - Data rate out.

Connect Time - The duration of the connect time.

FPS - The frames per second transmitted for video.
Horizontal Resolution - The screen resolution horizontally.
Vertical Resolution - The screen resolution vertically.
Refresh Rate - How often the screen is refreshed.
Protocol Version - RFB Protocol version.

To copy this information:

Click Copy to Clipboard. The information is available to be pasted
into the program of your choice.

Keyboard Options

Keyboard Macros

Keyboard macros ensure that keystroke combinations intended for the
target server are sent to and interpreted only by the target server.
Otherwise, they might be interpreted by the computer on which the
Virtual KVM Client is running (your client PC).

Macros are stored on the client PC and are PC-specific. Therefore, if you
use another PC, you will not see your macros. In addition, if another
person uses your PC and logs in under a different name, that user will
see your macros since they are computer-wide. Keyboard macros
created in the Virtual KVM Client are available in MPC and vice versa.

=i=Raritan.
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Building a Keyboard Macro

» To build a macro:

1. Click Keyboard > Keyboard Macros. The Keyboard Macros dialog
appears.

Click Add. The Add Keyboard Macro dialog appears.

3. Type a name for the macro in the Keyboard Macro Name field. This
name will appear in the Keyboard menu after it is created.

4. From the Hot-Key Combination field, select a keyboard combination
from the drop-down list. This allows you to execute the macro with a
predefined keystroke. Optional

5. Inthe Keys to Press drop-down list, select each key you would like to
use to emulate the keystrokes that will be used to perform the
command. Select the keys in the order by which they are to be
pressed. After each selection, select Add Key. As each key is
selected, it will appear in the Macro Sequence field and a Release
Key command will automatically be added after each selection.

6. For example, create a macro to close a window by selecting Left Ctrl
+ Esc. This will appear as the following in the Macro Sequence box:

Press Left Ctrl
Release Left Ctrl
Press Esc
Release Esc

7. Review the Macro Sequence field to be sure the macro sequence is
defined correctly.

a. Toremove a step in the sequence, select it and click Remove.

b. To change the order of steps in the sequence, click the step and
then click the up or down arrow buttons to reorder them as
needed.
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8. Click OK to save the macro. Click Clear to clear all field and start
over. When you click OK, the Keyboard Macros dialog appears and
lists the new keyboard macro.

Add Keyboard Macro

x]

Kevboard Macro Mame |C|Dse Window

Kevboard Macra Hotkey Mo Hot-Key -

Left Windows Key Release Left Ctrl
Right Windows Key Press ESC

Menu Key Release ESC
Print ScreenfSysRg

keys to Press Macro Sequence
All Keys T|
Murm Laock ﬂ Prezs Left Ctrl

Pausze
ESC |

Enter j

Add Kew | | Rermoue | | - | | u |

| (a]'4 || Cancel || Clear |

10 =i=Raritan.
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9. Click Close to close the Keyboard Macros dialog. The macro will now
appear on the Keyboard menu in the application. Select the new
macro on the menu to run it or use the keystrokes you assigned to
the macro.

Keyboard Macros [$_<|

¥ Vihrede 1=
Mimmize All Windows Foun Macro

j

Add

Rermoue

Maodify

Cloze

1]

Selact a macro from the above list,

Running a Keyboard Macro

Once you have created a keyboard macro, execute it using the keyboard
macro you assigned to it or by choosing it from the Keyboard menu.

Run a Macro from the Menu Bar

When you create a macro, it appears under the Keyboard menu.
Execute the keyboard macro by clicking on it in the Keyboard menu.

Run a Macro Using a Keyboard Combination

If you assigned a keyboard combination to a macro when building it, you
can execute the macro by pressing its assigned keystrokes. For
example, press the keys Ctrl+Alt+0 simultaneously to minimize all
windows on a Windows target server.

Modifying and Removing Keyboard Macros

» To modify a macro:

Choose Keyboard > Keyboard Macros. The Keyboard Macros dialog
appears.

Choose the macro from among those listed.
Click Modify. The Add/Edit Macro dialog appears.
Make your changes.

Click OK.

ok @D

11
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» Toremove a macro:

1. Choose Keyboard > Keyboard Macros. The Keyboard Macros dialog
appears.

Choose the macro from among those listed.

3. Click Remove. The macro is deleted.

Ctrl+Alt+Del Macro

Due to its frequent use, a Ctrl+Alt+Delete macro, used to reboot the
target computer, has been preprogrammed. Clicking on the

r-l-ﬁ_
Ctrl+Alt+Delete button in the toolbar sends this key sequence to
the server or to the KVM switch to which you are currently connected.

In contrast, if you were to physically press the Ctrl+Alt+Del keys, the
command would first be intercepted by your own PC due to the structure
of the Windows operating system, instead of sending the key sequence
to the target server as intended.

Setting CIM Keyboard/Mouse Options

> To access the DCIM-USBG2 setup menu:

Put the mouse focus on a window such as Note Pad (Windows) or
an equivalent.

2. Press Left-Control and Num Lock simultaneously. The CIM setup
menu will appear in the active window.

Set the language and mouse settings.

4. Exit the menu to return to normal CIM functionality.

Connection 1S3 Profile BEEEENENGE Video Mouse Tools  wew  Wirtual Media  Help

= = o Send Chl4+-Al-Del
E‘ % '—'E tﬁ" Se: CIM KeyboardMousz Optons

Irmoark Keyboard Macros. ..

Exoork KEeyboard Macros, .,

Keyboard Macros, .,

Minimize &l Windows ka4

1 =i=Raritan.
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Video Properties

i

Raritan.

Refresh Screen

The Refresh Screen command forces a refresh of the video screen.
Video settings can be refreshed automatically in several ways:

e The Refresh Screen command forces a refresh of the video screen.

e The Auto-sense Video Settings command automatically detects the
target server's video settings.

e The Calibrate Color command calibrates the video to enhance the
colors being displayed.

In addition, you can manually adjust the settings using the Video Settings
command.

P To refresh the video settings, do one of the following:
e Choose Video > Refresh Screen or click the Refresh Screen button

:g in the toolbar.

Auto-Sense Video Settings

The Auto-sense Video Settings command forces a re-sensing of the
video settings (resolution, refresh rate) and redraws the video screen.

» To automatically detect the video settings, do the following:

e Choose Video > Auto-sense Video Settings or click the Auto-Sense
Video Settings button #%: 1 in the toolbar. A message stating that the
auto adjustment is in progress appears.

Calibrate Color

Use the Calibrate Color command to optimize the color levels (hue,
brightness, saturation) of the transmitted video images. The color
settings are on a target server-basis.

Note: The Calibrate Color command applies to the current connection
only.

» To calibrate the color, do the following:
e Choose Video > Calibrate Color or click the Calibrate Color button

IEI in the toolbar. The target device screen updates its color
calibration.

13
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Video Settings

Use the Video Settings command to manually adjust the video settings.

P To change the video settings:
1. Choose Video > Video Settings or click the Video Settings button

% in the toolbar to open the Video Settings dialog.

2. Adjust the following settings as required. As you adjust the settings
the effects are immediately visible:

a. Noise Filter

The device can filter out the electrical interference of video
output from graphics cards. This feature optimizes picture quality
and reduces bandwidth. Higher settings transmit variant pixels
only if a large color variation exists in comparison to the
neighboring pixels. However, setting the threshold too high can
result in the unintentional filtering of desired screen changes.
Lower settings transmit most pixel changes. Setting this
threshold too low can result in higher bandwidth use.

b. Brightness: Use this setting to adjust the brightness of the target
server display.

c. Brightness Red - Controls the brightness of the target server
display for the red signal.

d. Brightness Green - Controls the brightness of the green signal.

e. Brightness Blue - Controls the brightness of the blue signal.
f.  Contrast Red - Controls the red signal contrast.

g. Contrast Green - Controls the green signal.

h. Contrast Blue - Controls the blue signal.

If the video image looks extremely blurry or unfocused, the
settings for clock and phase can be adjusted until a better image
appears on the active target server.

Warning: Exercise caution when changing the Clock and Phase
settings. Doing so may result in lost or distorted video and you may
not be able to return to the previous state. Contact Raritan Technical
Support before making any changes.

i. Clock - Controls how quickly video pixels are displayed across
the video screen. Changes made to clock settings cause the
video image to stretch or shrink horizontally. Odd number
settings are recommended. Under most circumstances this
setting should not be changed because the autodetect is usually
quite accurate.

=i=Raritan.
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j.  Phase - Phase values range from 0 to 31 and will wrap around.
Stop at the phase value that produces the best video image for
the active target server.

k. Horizontal Offset - Controls the horizontal positioning of the
target server display on your monitor.

I.  Vertical Offset - Controls the vertical positioning of the target
server display on your monitor.

3. Select Auto Color Calibration to enable this feature.
4. Select the video sensing mode:
= Best possible video mode

The device will perform the full Auto Sense process when
switching targets or target resolutions. Selecting this option
calibrates the video for the best image quality.

= Quick sense video mode

With this option, the device will use a quick video Auto Sense in
order to show the target's video sooner. This option is especially

useful for entering a target server's BIOS configuration right after
a reboot.

5. Click OK to apply the settings and close the dialog. Click Apply to
apply the settings without closing the dialog.

15
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Note: Some Sun background screens, such as screens with very dark
borders, may not center precisely on certain Sun servers. Use a different
background or place a lighter colored icon in the upper left corner of the
screen.

Viden Settings

Moise Filter < > 2
Brightness Red € | B 45
Brightness Green € | > B
Brightness Blue < I 3 46
ContrastRed ¢ I ¥ 192
Contrast Green £ I ¥ 186
ContrastBlue € I > 194
Clack < » 1056
Fhase £ X 19
Hotlzontal Offset 4 [ i 214
Vertical Offset L B 23
v &
& Bestpossible video mode
" Quick sense video mode
OKI Cancel I I

Using Screenshot from Target

You are able to take a screenshot of a target server using the
Screenshot from Target server command. You save this screenshot to a
file location of your choosing and can save it as either a bitmap, JPEG,
or PNG file.

» To take a screenshot of the target server:
1. Select Video > Screenshot from Target or click the Screenshot from

2
Target button [4'3’ on the toolbar.

2. Inthe Save dialog, choose the location to save the file, name the file,
and select a file format from the 'Files of type' drop-down.

=i=Raritan.
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3. Click Save to save the screenshot.

Saue jnt ([ My Downloads H |Eﬂ| |ﬁ| ||j| E:E: E:

[ Miscellaneous

|j| HTMLbackground.jpg

File name: Server Screenshntl

Files of type: [JPES image files -

Save || Cancel |

Mouse Options

When controlling a target server, the Remote Console displays two
mouse cursors: one belonging to your client workstation and the other
belonging to the target server.

You can operate in either single mouse mode or dual mouse mode.
When in dual mouse mode, and provided the option is properly
configured, the mouse cursors will align.

When there are two mouse cursors, the device offers several mouse
modes:

Absolute (Mouse Synchronization)

Intelligent (Mouse Mode)
Standard (Mouse Mode)

=i=Raritan. v
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Mouse Pointer Synchronization

When remotely viewing a target server that uses a mouse, you will see
two mouse cursors: one belonging to your remote client workstation and
the other belonging to the target server. When the mouse pointer lies
within the Virtual KVM Client target server window, mouse movements
and clicks are directly transmitted to the connected target server. While
in motion, the client mouse pointer slightly leads the target mouse pointer
due to mouse acceleration settings.

On fast LAN connections, you may want to disable the Virtual KVM
Client mouse pointer and view only the target server's pointer. You can
toggle between these two modes (single mouse and dual mouse).

Mouse Synchronization Tips
Be sure to follow these steps when configuring mouse synchronization:

1. Verify that the selected video resolution and refresh rate are among
those supported by the device. The Virtual KVM Client Connection
Info dialog displays the actual values that the is seeing.

2. Verify that the cable length is within the specified limits for the
selected video resolution.

3. Verify that the mouse and video have been properly configured
during the installation process.

4. Force an auto-sense by clicking the Virtual KVM Client auto-sense
button.

5. If that does not improve the mouse synchronization (for Linux, UNIX,
and Solaris KVM target servers):

a. Open a terminal window.
b. Enter the xset mouse 1 1 command.

c. Close the terminal window.

6. Click the "Virtual KVM Client mouse synchronization™ button ”}

=i=Raritan.



=& Raritan.

Chapter 2: Virtual KVM Client (VKC)

Additional Notes for Intelligent Mouse Mode

e Be sure that there are no icons or applications in the upper left
section of the screen since that is where the synchronization routine
takes place.

e Do not use an animated mouse.
¢ Disable active desktop on KVM target servers.

Synchronize Mouse

In dual mouse mode, the Synchronize Mouse command forces
realignment of the target server mouse pointer with Virtual KVM Client
mouse pointer.

P To synchronize the mouse, do one of the following:
e Choose Mouse > Synchronize Mouse or click the Synchronize

Mouse button in the toolbar.

Standard Mouse Mode

Standard Mouse mode uses a standard mouse synchronization
algorithm using relative mouse positions. Standard Mouse mode requires
that mouse acceleration is disabled and other mouse parameters are set
correctly in order for the client and server mouse to stay synchronized.
Standard Mouse mode is the default.

» To enter standard mouse mode:
e Choose Mouse > Standard.
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Intelligent Mouse Mode

In Intelligent Mouse mode, the device can detect the target mouse
settings and synchronize the mouse cursors accordingly, allowing mouse
acceleration on the target. In this mode, the mouse cursor does a
“dance” in the top left corner of the screen and calculates the
acceleration. For this mode to work properly, certain conditions must be
met.

» To enter intelligent mouse mode:
e Choose Mouse > Intelligent.

Intelligent Mouse Synchronization Conditions

The Intelligent Mouse Synchronization command, available on the
Mouse menu, automatically synchronizes mouse cursors during
moments of inactivity. For this to work properly, however, the following
conditions must be met:

e The active desktop should be disabled on the target.
¢ No windows should appear in the top left corner of the target page.

e There should not be an animated background in the top left corner of
the target page.

e The target mouse cursor shape should be normal and not animated.

e The target mouse speeds should not be set to very slow or very high
values.

e Advanced mouse properties such as “Enhanced pointer precision” or
“Snap mouse to default button in dialogs” should be disabled.

e Choose “Best Possible Video Mode” in the Video Settings window.

e The edges of the target video should be clearly visible (that is, a
black border should be visible between the target desktop and the
remote KVM console window when you scroll to an edge of the
target video image).

e When using the intelligent mouse synchronization function, having a
file icon or folder icon located in the upper left corner of your desktop
may cause the function not to work properly. To be sure to avoid any
problems with this function, Raritan recommends you do not have file
icons or folder icons in the upper left corner of your desktop.

After autosensing the target video, manually initiate mouse
synchronization by clicking the Synchronize Mouse button on the toolbar.
This also applies when the resolution of the target changes if the mouse
cursors start to desync from each other.

If intelligent mouse synchronization fails, this mode will revert to standard
mouse synchronization behavior.

=i=Raritan.
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Please note that mouse configurations will vary on different target
operating systems. Consult your OS guidelines for further details. Also
note that intelligent mouse synchronization does not work with UNIX
targets.

Absolute Mouse Mode

In this mode, absolute coordinates are used to keep the client and target
cursors in sync, even when the target mouse is set to a different
acceleration or speed. This mode is supported on servers with USB
ports.

» To enter absolute mouse mode:
e Choose Mouse > Absolute.

Note: The absolute mouse setting requires a USB target system and is
the recommended mouse setting for KX I1-101.

Note: Absolute Mouse Synchronization is available for use with the
virtual media-enabled USB CIM (D2CIM-VUSB and D2CIM-DVUSB)
only.

i
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Single Mouse Cursor

Single Mouse mode uses only the target server mouse cursor and the
local mouse pointer no longer appears onscreen. While in single mouse
mode, the Synchronize Mouse command is not available (there is no
need to synchronize a single mouse cursor).

> To enter single mouse mode, do the following:
1. Choose Mouse > Single Mouse Cursor.

2. Click the Single/Double Mouse Cursor button [} in the toolbar.

£ Single Cursor Mode

You are abowut to enter Single Cursor mode. While you are in this mode,
this software will have exclusive control over the mouse and keyhoard.
To exit Single Cursor mode you must press:

Ctri+Al+0

I iScale the video {no scroll bars):
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» To exit single mouse mode:
1. Press Ctrl+Alt+O on your keyboard to exit single mouse mode.

Tool Options

From the Tools menu, you can specify certain options for use with the
Virtual KVM Client, including logging, setting the keyboard type, and
defining hot keys for exiting Full Screen mode and Single Cursor mode.

> To set the tools options:
1. Choose Tools > Options. The Options dialog appears.

2. Select the Enable Logging checkbox only if directed to by Technical
Support. This option creates a log file in your home directory.

3. Choose the Keyboard Type from the drop-down list (if necessary).
The options include:

= US/International

= French (France)

= German (Germany)
= Japanese

= United Kingdom

= Korean (Korea)

= Belgian (Belgium)

= Norwegian (Norway)
= Danish (Denmark)

=  Swedish (Sweden)

=  German (Switzerland)
= Hungarian (Hungary)
= Spanish (Spain)

= |talian (Italy)

= Slovenian

4. Exit Full Screen Mode - Hotkey. When you enter Full Screen mode,
the display of the target server becomes full screen and acquires the
same resolution as the target server. This is the hot key used for
exiting this mode.

5. Exit Single Cursor Mode - Hotkey. When you enter single cursor
mode, only the target server mouse cursor is visible. This is the hot
key used to exit single cursor mode and bring back the client mouse
cursor.
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6. Click OK.

Keyboard Limitations
Slovenian Keyboards

The < key does not work on Slovenian keyboards due to a JRE
limitation.

Language Configuration on Linux

Because the Sun JRE on Linux has problems generating the correct Key
Events for foreign-language keyboards configured using System
Preferences, Raritan recommends that you configure foreign keyboards
using the methods described in the following table.

Language Configuration method

US Intl Default

French Keyboard Indicator

German System Settings (Control Center)
Japanese System Settings (Control Center)
UK System Settings (Control Center)
Korean System Settings (Control Center)
Belgian Keyboard Indicator

Norwegian Keyboard Indicator

Danish Keyboard Indicator

Swedish Keyboard Indicator

Hungarian System Settings (Control Center)
Spanish System Settings (Control Center)
Italian System Settings (Control Center)
Slovenian System Settings (Control Center)

Note: The Keyboard Indicator should be used on Linux systems using
Gnome as a desktop environment.

23
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View Options

View Toolbar
You can use the Virtual KVM client with or without the toolbar display.

» To toggle the display of the toolbar (on and off):
e Choose View > View Toolbar.

Scaling

Scaling your target window allows you to view the entire contents of the
target server window. This feature increases or reduces the size of the
target video to fit the Virtual KVM Client window size, and maintains the
aspect ratio so that you see the entire target server desktop without
using the scroll bar.

» To toggle scaling (on and off):
e Choose View > Scaling.

Target Screen Resolution

When you enter Full Screen mode, the display of the target server
becomes full screen and acquires the same resolution as the target
server. The hot key used for exiting this mode is specified in the Options
dialog (the default is Ctrl+Alt+M).

> To enter full screen mode:
e Choose View > Full Screen.

> To exit full screen mode:

Press the hot key configured in the Tools Options dialog. The default is
Ctri+Alt+M.
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Help Options

=i=Raritan.

About Raritan Virtual KVM Client

This menu command provides version information about the Virtual KVM
Client, in case you require assistance from Raritan Technical Support.

» To obtain version information:
e Choose Help > About Raritan Virtual KVM Client.

Use the Copy to Clipboard button to copy the information contained in
the dialog to a clipboard file so it can be accessed later when dealing
with support (if needed).

About Raritan Virtual KNM Client

Zi=Raritan.

Raritan Wirtaal KM Client
Version 2.1.0.1.4

JuM Wersion 1.5.1_10
M Mendor  Sun Microsyskens Inc.
Cperating System  Windows £
Cperating Syskem Yersion 5.1
Syshem Architecsture =36

Copyraht () 2004-2008 Raritan Computer, Inc, &l rights reservad,

[ Copy ko Clipboard H Close
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Multi-Platform Client and Raritan
Remote Client

Raritan Multi-Platform Client (MPC) and Raritan Remote Console are
graphical user interfaces for the Raritan product lines, providing remote
access to target servers connected to Raritan KVM over IP devices.
Non-Windows users must use Raritan Multi-Platform Client and
Windows® users running Internet Explorer must use Raritan Remote
Client.

In This Chapter

Requirements and Installation .............ocoveeoiiiiiiiii e 26
OPEIALION ..ttt 54
Administrative FUNCHIONS ........cooiiiiiiiiiiiccii e 124

Requirements and Installation

i

Raritan.

MPC Requirements and Installation Instructions

Note to CC-SG Users

If you are using Dominion KX Il in a CC-SG configuration, do not use the
CC-SG proxy mode if you are also planning to use the Multi-Platform
Client (MPC).

MPC Minimum System Requirements

The minimum system requirements for the Multi-Platform Client are:

e CPU Speed: 1.0 GHz
e RAM: 512 Mbytes

Note: Running the client software on system configurations below either
of these specifications may impact performance and result in errors.
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MPC Supported Operating Systems and Browsers

Operating Systems

When launched as a web applet or as a standalone application, MPC
allows you to reach target servers via different Raritan Dominion devices
and IP Reach models.

Raritan MPC is compatible with the following platforms:
e Windows XP

e Windows 2000 SP4

e Windows Vista

e Red Hat Linux® 9.0

¢ Red Hat Enterprise Workstation 3.0 and 4.0

e SUSE Linux Professional 9.2 and 10

e Fedora Core 5 and above

e Mac®

e Solaris™

Note: If you are using a Mac 10.5, use Java 1.4.2.x in order to avoid
possible text length issues in the MPC interface. Specifically, IP
addresses in the MPC Navigator and menu text may be cut off if you are
not using Java 1.5.x with 10.5.

At this time, the JRE plug-in is available only for the Windows 32-bit
operating system. So MPC and VKC should be launched only from a
32-bit browser since plug-ins will only work in a 32-bit browser. Installing
a 32-bit JRE will install the 32-bit JRE plug-in.

Following are the Java 32-bit and 64-bit Windows operating system
requirements.

Mode Operating system Browser
Windows x64  Windows XP e |E6.0SP1+o0r7.0
32-bit mode e Mozilla1l.4.X or 1.7+

e Netscape 7.X
e Firefox 1.06+

Windows Server 2003 e |E6.0SP1+
e Mozillal.4.Xor 1.7+

e Netscape 7.X
e Firefox 1.06+

Windows Vista e |E7.0+
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Windows XP 64bit OS, 32bit Browsers:
Windows x64
64-bit mode Windows XP e |E6.0SP1+o0r7.0
Professional e Mozillal.4.Xor 1.7+
Windows XP Tablet * Netscape 7.X

e Firefox 1.06+
64bit mode, 64bit Browsers:
e N/A

Windows Vista
Windows Server 2003
Windows Server 2008

Browsers

MPC supports the following browsers:
e Internet Explorer 6, 7 and 8

e Firefox® 1.5, 2.0 and 3.0

e Mozilla® 1.7

e Safari 2.0

Note: If you are using IE 7, you may run into permission issues when
trying to connect to a target server. To avoid this, do the following:

1. In IE7, click Tools > Internet Options to open the Internet Options
dialog.

2. In the "Temporary Internet files" section, click the Settings button. The
Settings dialog opens.

3. In the "Check for newer versions of stored pages" section, select
Automatically.

4. Click OK to apply the settings.

Note to IPv6 Users

Due to a browser limitation, MPC cannot be downloaded via the KX IPv6
address from Mozilla 1.7 if Pop-up Manager is enabled. Do one of the
following to avoid this issue:

e Use the hostname of the device for the MPC browser download.

e Set Mozilla to not block Pop-up windows via edit\Preferences\Privacy
and Security.

e Use IPV4 address.
e Use standalone MPC.
e Use the latest version of Firefox.
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Special Characters in MPC

The following table identifies the special characters that can be used in

MPC:

Character

Description
Exclamation point

Double quote
Pound sign
Dollar sign
Percent sign
Ampersand
Single quote
Left parenthesis
Right parenthesis
Asterisk

Plus sign
Comma

Dash

Period

Forward slash

Less than sign

Character

Installing and Opening Standalone MPC

Description
Colon

Semi-colon
Equal sign
Greater than sign
Question mark
At sign

Left bracket
Backward slash
Right bracket
Caret
Underscore
Grave accent
Left brace

Pipe sign

Right brace
Tilde

Raritan recommends that you open only one standalone MPC session at
a time. Opening more than one standalone MPC session on the same
client at the same time may cause performance problems and system

errors.

Important: MPC modem connectivity is supported on Windows,
Linux, and Sun Solaris but not Macintosh. When working in

Windows, use Standalone MPC.
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You must have the MPC JAR file to install MPC for any of these
operating systems.

» To check for the MPC JAR file:

1. Download the installation file, MPC-installer.jar from the Raritan
website (www.raritan.com) on the Support - Firmware Upgrades
page. Click Dominion Family and scroll to the Standalone
Multi-Platform Client link.

2. If copying MPC-installer.jar from a known location, double-click the
file to start installation.

Windows

> To check the JRE version in Windows:
1. Do one of the following to check the JRE version in Windows:

= Determine your version of the JRE from the Java website:
http://www.java.com/en/download/help/testvm.xml.

= Click the Windows Start button at the bottom left of your page
and click Control Panel.

Tip: In the upper left corner of the page, you may see a panel named
Control Panel with the option Switch to Classic View or Switch to
Category View. For easier viewing, opt for Classic View.

a. Search the Control Panel files for a Java icon. When you locate
the Java icon, double-click it to open the Java Control panel.
Click the General tab and then click the About button to check
the current Java Runtime Environment (JRE).

b. If the JRE is version 1.4.2_05 or later, proceed with the MPC
Installation. If the Java icon does not exist in the Control Panel or
if the JRE version is prior to 1.4.2_05, go to the Sun
Microsystems website at http://java.sun.com/products/ to
download the latest version of JRE.

2. For future Java access and to automatically open it, set your path to
the Java executable.

a. Right-click the My Computer icon on your desktop and click
Properties.

b. Click the Advanced tab and then click "Environment variables".

c. Edit the Path address so that it contains the path to the Java
executable.
For example, if Java is installed on C:\j2re1.4.2_05 and your
path is currently set to C:\WINDOWS\SYSTEM32, then change
the path to read C:\WINDOWS\SYSTEM32;C:\j2rel1.4.2_05
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To install MPC for Windows:

1. Download the MPC-installer.jar installation file or copy the file from a
known location.

Double-click the jar file icon to open the installation dialog.
After the initial dialog appears, click Next.

@8 IzPack - Installation of Raritan Multi-Platform Client

4. Choose the directory where you want to install MPC and click Next.
Click Browse to locate a non-default directory.

=&=Raritan. 7
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5. Click Next.

@8 IzPack - Installation of Raritan Multi-Platform Client

|Accessaries
(AuthorT Y4
|Lxialis Software
|cc application
|Rartan

[Raritanfaritan Muti-Platform Clientid 4017 |

6. Inthe Shortcut dialog, choose a shortcut location, determine who
should have the shortcut, and determine whether you want the
shortcut on the desktop. When finished, click Next.

32
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Once the installation is complete, the final dialog indicates where you
will find an uninstaller program and provides an option for generating
an automatic installation script. Click Done to close the Installation
dialog.

a8 1zPack - Installation of Raritan Multi-Platform Client i 1 ] [

6 Installation has completed successtully,

i’ An uninstaller program has besh crested in:
CProgram Files'Raritan'Raritan Multi-Platform Client'd 401 P ninstaller

_" Generate an automatic installation script

[Made with [zPack - http: ifaeveve izforge .coml)

» To open MPC in Windows:

Click the Windows Start menu and then choose All Programs >
Raritan Multi-Platform Client. Alternatively, double-click the MPC
desktop shortcut icon if you created one.

2. Double-click the desired device in the Navigator to establish a
connection.

3. Type your user name and password in the device dialog and then
click OK to log on.

Linux

Raritan recommends using Java® Runtime Environment (JRE) version
1.5 for optimum performance but MPC will function with JRE version
1.4.2_05 or greater (with the exception of JRE 1.5.0_02). JRE 1.6 is also
supported but has not been fully tested.

Determine your version of the JRE from the Java website:
http://www.java.com/en/download/help/testvm.xml.

You may need some configuration depending on your OS and browser.
Configuration instructions are provided with the JRE download.

Important: When launching MPC from a browser, it is highly
recommended that you disable the Java Applet caching.

33



Chapter 3: Multi-Platform Client and Raritan Remote Client

Although no actual problems have occurred when Java caching is turned
on, some non-impacting Java exceptions have occurred. Generation of
these Java-exceptions can appear in the Java Applet Console window
and may degrade performance.

For Linux/UNIX environments, the Java Control Panel is located in the
JRE's bin directory; the location varies based on where JRE was
installed by your Linux/UNIX administrator.

Tip: It is also recommended that you clear the Java cache.

> To disable Java caching and clear the cache (use these steps
with Microsoft Windows XP and JRE 1.5.0):

1. From the Start menu, click Control Panel.

2. Double-click on the Java icon to launch it. The Java Control Panel
dialog appears.

‘. Java Control Panel 10} x|

i Abouk

Wiew version infarmation abouk Java Control Panel,

About... |

. Mebwark Settings

Mebwork settings are used when making Inkernet conneckions, By defaulk, Java
will use the network settings in your web browser, Cnly advanced users should
modify these settings.

Metwork Setkings...

— Temporary Internet Files

Files you Use in Java applications are stored in a special Folder Far quick execution
later, Only advanced users should delete files or modify these settings,

Celete Files.., | Setkings... |

ITI Cancel | Apply

3. To disable Java caching:

==
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a. From the General tab, click the Settings button. The Temporary
Files Settings dialog appears.

Temporary Files Settings g

Delete Files., ., |

x|

Wiew Applications. ., |

—Setkings

Location:

Arnount af disk
space ko use:

Jar compressian:

Iil:un Data\surtJava\Deploymenticache . Change... I

+ Unlimited
" Maximurn |

e ]

H | I | | | | |

|
High

oK Zancel

b. Click the View Applets button. The Java Applet Cache Viewer

opens.

Java Applet Cache Yiewer 1l =100xl
File  Options Help
Marne Type Size Expiration Date Last Modified “ersion | URL
rclang_en.jar-1d66ds02-222771... | Jar GKE 12/31/69 07:00 PM| 1129006 02:20 PM| M/& https:f}192.1658.61. 180/ rclang_en.jar ;I
rclang_en.jar-63ebSffc-5e9a217. .. | Jar 6KE 12/31/69 07:00 PM| 12/21/06 02:35 PM| /& https:fi192.165.59. 45 rclang_en. jar
rclang_en.jar-68eb6070-5c7a7a. .. | Jar GKE 1251 /69 07:00 PM| 1129006 02:20 PM| N/& https:/}192.1658.59. 80 rclang_en.jar
sClientLib. jar-5444cd6d-7d6268. .. | Jar SBSKE | 12/31/69 07:00 PM| 0Z/26/00 02:11 ... | WA https:/192.168.50,29/sClientLib. jar
sClientLib. jar-7036985-4703645. ., | Jar SESKE | 12/31/69 07:00 PM| 02/26/00 01:15 ... |M/6 https: /192, 168,50, 154/ sClientLib. jar
sClientLib.jar-7824070-6f67F aae. .. | Jar 619KB | 12/31/69 07:00 PM| 05/22/06 07:02 FM| MN]A https:/{192.168.59, 222/sClientLib. jar
sFoxtrot.jar-1a581382-6259a44, .. | Jar S4KE 12)31 /69 07:00 PM| 10/09/06 12:12 PM| M/A http:}isdeweb raritan.comjreleases/MulkiPlatforr
sFoxtrot. jar-4662ffd-500bc4f9 . zip | Jar S4kE 123169 07:00 PM| 0Z/26/00 01:15 ... |M/& https:f192.165.50. 154 sFoxtrot. jar
sFoxtrat.jar-4e50382-19cFfa06. 2ip | Jar S4KE 123169 07:00 PM| 01/29/07 01:57 PM| MN]A https:/{192.168.59, 150/sFoxtrat. jar
sFoxtrot. jar-4e506e8-75cd7bec.. .. | Jar S4kE 1213169 07:00 PM| 05/ 22/06 07:03 PM| /A https:f/192.165.59, 222 /sFoxtrot. jar
sFoxtrot.jar-51a793dc-416bead. .. | Jar S4kE 12/31/69 07:00 PM| 02/26{00 02:11 ... |M/A https:f{192.1658.50, 29 sFoxkrot. jar
sHIM.jar-13984d35-5ce3ca3d.zip | Jar Z1G9KE | 12/31/69 07:00 PM| 02/26/00 01:15 ... | MJA https: /{192 168,50, 154/sHM . jar
sHM.jar-14172423-33 1aBacs.zip | Jar 2523KE | 12/31/69 07:00 PM| 05/22/06 07:03 PM| N4 https:/{192.168.59, 222{sHM, jar
sHM.jar-60dSb117-6ca6b084.2ip | Jar Z189KE | 12/31/69 07:00 PM| 02/26/00 02:11 ... | MJA https:/192.168.50, 29/sHM. jar
sMpc. jar-4Fc27F70-4Fc4306F zip | Jar 3712KE | 12/31/69 07:00 PM| 01/29/07 01:57 PM| N}A https:/{192.168.59, 150/sMpc. jar
sMpe.jar-799f6ef0-2c5cab18.zip | Jar 3181KE | 12/31/69 07:00 PM| 10/09/06 12:12 PM|N/A http:f{sdeweb,raritan. com/releasesMulkiPlatForr «
q [ 3
I Enable Caching

Refresh | Delete | Ok I
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c. Deselect the Enable Caching checkbox if it is already checked.
d. Click OK.

4. To clear the Java cache:

a. From the Temporary Files Settings dialog, click the Delete Files
button. The Delete Temporary Files dialog appears.
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b. Select the temporary files that you want to delete.

Delete Temporary Files 1 El

D ] l Delete the Following kempaorary Files?
-

v Downloaded Applets
v Downloaded applications

Zancel |

[+ Cther Files

5. Click OK.

» To check the JRE version in Linux:
In a graphical environment, open a terminal dialog.

2. Type java version in the command line and press Enter on your
keyboard. The currently-installed version of Java Runtime
Environment (JRE) is displayed.

If your path variable is not set to where the java binaries have been
installed, you may not be able to see the JRE version.

3. Set your path:

a. To setyour path and assuming JRE 1.4.2_05 is installed in
lusr/local/java: you must set your PATH variable.

b. To set the path for bash shell, export
PATH=$PATH:/usr/localljava/j2rel.4.2_05/bin.

c. To set the path for tcsh or csh, set PATH = ($PATH
lusr/local/javal/j2rel.4.2_05/bin).

These commands can be typed at the terminal each time you login.
Alternatively, you can add it to your .bashrc for bash shell, .cshrc for
csh, or tcsh so that each time you login the PATH is already set.
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Chapter 3: Multi-Platform Client and Raritan Remote Client

See your shell documentation if you encounter problems.

usrl@localhost:~

FEile Edit Wiew Terminal Tabs Help

[usrl@localhost ~]% java -version

java version "1.4.2_086"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_06-b03)
Java HotSpot(TM) Client VM (build 1.4.2_06-b03, mixed mode)
[usrl@localhost ~1% |:|

[2]

[«]

4. |If the JRE is version 1.4.2_05 or higher, proceed with the MPC
installation. If the version is prior to 1.4.2_05, go to the Java website
at http://java.sun.com/products/ to download the latest Runtime
Environment.

P To install MPC for Linux:
You must have Administrative privileges to install MPC.
1. Download the MPC-installer.jar file or copy it from a known location.

2. Open a terminal dialog and open the directory where the installer is
saved.

3. Type java -jar MPC-installer.jar and press Enter to run the installer.
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4. After the initial page loads, click Next.

! NtEach e neailaon ar AR aR M e il

@ Select the installation path:

|.-'usr.n'local.n’Raritan.n’Raritan Multi-Platform Client/4 4017 B Browse... |

{Made with [zPack - hitp:/ fvwwy izforge.com/f)

OPrevious |

5. Use the Browse function to select a directory to install MPC if the
directory is different from the default path displayed in the "Select the
installation path" field.

6. Click Next to open the Shortcut dialog.
7. On the Shortcut dialog:

= Choose a shortcut location from the "Select a Program Group for
the Shortcuts:" field.

= Select either "current user" or "all users" to define who should
have access to the shortcut.

= Check the "Create shortcut on the desktop" checkbox if you want
the shortcut to appear on the desktop.
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8. When finished, click Next.

Select a Program Group for the Shortcuts:

Raritan
create shartcut for
(% current user

(Call users

IRaritam’Raritan hulti-Platform Client/4.40.1.7 Reset |

[ Create shortcut on the desktop

{Made with [zPack - hitp:/ fvwwy izforge.com/f)

OPrevious |

Note: Once MPC is installed successfully, a shortcut will be available
on the desktop. However, for Linux users, you will need to log off of
and then back into your session before the shortcut will be visible on

the desktop.

Once the installation is complete, the final page indicates where you
will find an uninstaller program and provides you with the option to
generate an automatic installation script.
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9.

! T afﬁ;rnanMuIn—PlatfnrmCI_|er|t— R EEEERERRIE———————NNm..

Click Done to close the Installation dialog.

@ Installation has completed successfully.

6 An uninstaller program has been created in:
fusrflocalfRaritan/ Raritan Multi-Platfarm Client/4.40.1.7 {Uninstaller

' Generate an automatic installation script

{Made with [zPack - hitp:/ fvwwy izforge.com/f)

To open MPC in Linux:

Open a terminal window and change directories to the directory
where you installed MPC (default location: /usr/local/Raritan/Raritan
MPC/4.40.1.71).

Type ./start.sh and press Enter to open MPC.

Double-click the desired device to establish a connection, type your
user name and password, and click OK to log on.

Solaris
To check the JRE version for Sun Solaris:

1.
2.

Launch a terminal window on the Sun Solaris desktop.

Type java version in the command line and press Enter. The
currently-installed version of Java Runtime Environment (JRE)
appears.

If your path variable is not set to where the java binaries have been
installed, you may not be able to see the JRE version.

a. To setyour path and assuming JRE 1.4.2_05 is installed in
lusr/local/java, you must set your PATH variable.

b. To set path for bash shell, export
PATH=$PATH:/usr/locall/javal/j2rel.4.2_05/bin.

c. To set path for tcsh or csh, set PATH = ($PATH
lusr/local/java/j2rel.4.2_05/bin).

=i=Raritan.
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3. These commands can be typed at the terminal each time you login.
Alternatively, you can add it to your .bashrc for bash shell, .cshrc for
csh, or tcsh so that each time you login the PATH is already set. See

your shell documentation if you encounter problems.

Terminal

# java -version

jawa version "1.4.2_05"

Jawal(TM} 2 Runtime Environment, Standard Edition Cbuild 1.4.2_05-b04)
Jawa HotSpot(THM) Client WM Cbuild 1.4.2_05-b04, nixed mode)

#

>

If the JRE is version 1.4.2_05 or higher, proceed with the MPC
installation. If the version is prior to 1.4.2_05, go to the Sun website
at http://java.sun.com/products/ to download the latest Runtime
Environment.

To install MPC for Sun Solaris:

You must have administrative privileges to install MPC.

1.
2.

Download the MPC-installer.jar file or copy it from a known location

Open a terminal window and navigate to the directory where the
installer is saved.

Type java -jar MPC-installer.jar and press Enter to run the installer.
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4. After the initial page loads, click Next.

IzFack — Installation of Raritan Multi-Platform Client

5. Use the Browse function to navigate to the directory you want to
install MPC or select the default directory displayed in the "Select the
installation path" field.

Click Next.
When installation is complete, click Next.
Click Next again.

Once the installation is complete, the final dialog will indicate where
you will find an uninstaller program and provides the option to
generate an automatic installation script.

. ==Raritan.
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9. Click Done to close the Installation dialog.

IzFack — Installation of Raritan Multi-Platform Client

To open MPC in Sun Solaris:

1. Open aterminal window and navigate to the directory where you
installed MPC (the default location is /usr/local/Raritan/Raritan
MPC/4.40.1.7).

Type ./start.sh and press Enter to open MPC.

Double-click the desired device to establish a connection, type your
user name and password, and click OK to log on.

Macintosh

» To check JRE on Macintosh:
1. Launch aterminal window on the Macintosh desktop.
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2. Type the java version in the command line and press Enter. The
currently-installed version of the Java Runtime Environment (JRE) is

displayed.
r ; )
o6 Terminal — sh — 80x24
Last login: Tue Mar 22 A9:64:25 on ttypl =]

Welcome to Darwin!

Raoritan-MIS-Computer :~ root# jawa —version

jowa version "1.4.2_B5"

Java(TM} 2 Runtime Envirorment, Stondord Edition (build 1.4.2_A5-141.3)
Java HotSpot{TH} Client YM (build 1.4.2-38, mixed mode)
Raritan-MIS-Computer i~ root# I

A

3. |Ifthe JRE is version 1.4.2_05 or higher, proceed with the MPC
installation. If the version is prior to 1.4.2_05, go to the Apple website
to download the latest Runtime Environment.

» To install MPC on a Mac:
You must have administrative privileges to install MPC.
1. Download the MPC-installer.jar file or copy it from a known location.

2. Open a Finder window and locate the installer.

3. Double click the MPC-installer.jar file to run the installer.
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4. After the initial dialog appears, click Next.

ra e0n |1zPack - Installation of Raritan Multi-Platform Client

[ Select the installation path:

.[I_,_f_.A_P_p_Iications_f Raritan/Raritan Multi-Platform Client_,f4.40.1.? 1

(Made with |zPack - http:/ /www.izforge.com/)

CPrevious) (-—Nﬂih-) ( Quit )

5. Use the Browse function to select a directory to install MPC if the
directory is different from the default path displayed in the "Select the
installation path" field.

6. When installation is complete, click Next.

Once the installation is complete, the final dialog indicates where you
will find an uninstaller program and provides you with the option to
generate an automatic installation script.

7. Click Done to close the Installation dialog.
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@ Network
@ Macintosh HD
&~

ﬁ raritancompu..

=@ Applications

ﬁ Desktop

» To open MPC on a Mac:

1. Open a Finder window and navigate to the directory where you
installed MPC (the default location is /Applications/Raritan/Raritan

MPC/4.40.1.7).

|A Applications

Date Modified

= s
@ Internet Connect
ﬁ Internet Explorer
'#, iPhoto
& isync
J iTunes
B Mail
‘& Microsoft AutoUpdate
» [ Office 2004 for Mac Test Drive
ﬂ OmniGraffle
& omnioutliner
W Preview
» [ QuickBooks NUE &
€} QuickTime Player
v [J Raritan
v [ Raritan Multi-Platform Client
v [F 44017
2 Raritan Multi-Platform Client
» [ uninstaller

ST L, COUT, TIOU T T

Jan 27, 2005, 9:21 AM
Jun 3, 2003, 5:14 PM
Feb 11, 2005, 5:16 PM
Jun 16, 2004, 7:39 PM
May 19, 2005, 4:15 PM
Aug 14, 2003, 3:00 PM
Feb 11, 2005, 5:43 PM
Jan 19, 2005, 11:24 AM
Sep 1, 2004, 7:05 PM
Sep 1, 2004, 7:04 PM
Jan 27, 2005, 9:20 AM
Sep 1, 2004, 6:59 PM
May 25, 2005, 6:07 PM
Today, 3:31 PM
Today, 3:31 PM
Today, 3:31 PM
Today, 3:31 PM
Today, 3:31 PM

~ 1of40 selected, 63.43 GB available.

2. Double-click the desired device to establish a connection, type your
user name and password, and click OK to log on.

"®O 0

I1zPack - Installation of Raritan Multi-Platform Client

6 Installation has completed successfully.

&# An uninstaller program has been created in:
fApplications /Raritan/Raritan Multi-Platform Client/4.40.1.7 /Uninstaller

(Generate an automatic installation script)

(Made with |zPack - http:/ /www.izforge.com/)
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3. Open a Finder window and navigate to the directory where you
installed MPC (the default location is /Applications/Raritan/Raritan

MPC/4.40.1.7).

|_% Applications

Qr everywhere

E =
@ Internet Connect
g Internet Explorer
5 iPhoto

© isync

@ iTunes

& Mail

‘& Microsoft AutoUpdate

> [_; Office 2004 for Mac Test Drive

2} omniCraffle
&y omnioutliner
% Preview

| » [ QuickBooks NUE &

4 QuickTime Player

| v [ Raritan

v [ Raritan Multi-Platform Client
v [J 44017
- Raritan Multi-Platform Client
> [,-3 Uninstaller
-

Date Modified
ST L LOUN, T IOU T

Jan 27, 2005, 9:21 AM
Jun 3, 2003, 5:14 PM
Feb 11, 2005, 5:16 PM
Jun 16, 2004, 7:39 PM
May 19, 2005, 4:15 PM
Aug 14, 2003, 3:00 PM
Feb 11, 2005, 5:43 PM
Jan 19, 2005, 11:24 AM
Sep 1, 2004, 7:05 PM
Sep 1, 2004, 7:04 PM
Jan 27, 2005, 9:20 AM
Sep 1, 2004, 6:59 PM
May 25, 2005, 6:07 PM
Today, 3:31 PM

Today, 3:31 PM

Today, 3:31 PM

Today, 3:31 PM

Today, 3:31 PM

1 of 40 selected, 63.43 GEB available

4. Double-click the desired device to establish a connection, type your
user name and password, and click OK to log on.

Opening MPC from a Web Browser

Important: Regardless of the browser you use, you must allow
pop-ups from the Dominion device's IP address in order to open

MPC.

1. To open MPC from a client running any supported browser, type
http://IP-ADDRESS/mpc into the address line, where IP-ADDRESS
is the IP address of your Raritan device. MPC will open in a new

window.

Note: The Alt+Tab command will toggle between windows only on

the local system.

When MPC opens, the Raritan devices that were automatically
detected and which are found on your subnet are displayed in the

Navigator in tree format.

2. If your device is not listed by name in the navigator, add it manually:

a. Choose Connection > New Profile. The Add Connection window

opens.
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3.

b. Inthe Add Connection window, type a device Description,
specify a Connection Type, add the device IP address, and click
OK. These specifications can be edited later.

In the Navigator panel on the left of the page, double-click the icon
that corresponds to your Raritan device to connect to it.

Note: Depending on your browser and browser security settings, you
may see various security and certificate check and warning messages. It
is necessary to accept the options in order to open MPC.

Note: If you are using FireFox 3.0.3, you may experience problems
launching the application. If this occurs, clear the browser cache and
launch the application again.

Modem Connectivity in MPC

>

To make modem connectivity available on Unix, Linux, and Mac
OS for non-root users:

As the root, change the group for /etc/ppp directory and required
files:

a. chgrp uucp /etc/ppp

b. chgrp uucp /etc/ppp/pap-secrets

c. chgrp uucp /etc/ppp/peers

Change the permissions for /etc/ppp chmod g+rwx /etc/ppp

Change the permissions for /etc/ppp/pap-secrets chmod g+rwx
letc/ppp/pap-secrets

Change the permissions for /etc/ppp/peers chmod g+rwx
letc/ppp/peers

Set the suid bit to pppd chmod u+s /usr/shin/pppd (/usr/bin/pppd
depending on the location of pppd)

Assign users to the uucp group:
a. lusr/sbin/usermod -G {existing groups for userl},uucp userl

b. /usr/shin/usermod -G {existing groups for user2},uucp user2, and
so forth.

When logged on as the normal user, update the path for access to
pppd and the chat export PATH=$PATH:/usr/sbin (/usr/bin
depending on the location of pppd).

Note: For both root and non-root users, ensure that the options file exists
under /etc/ppp
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RRC Requirements and Installation Instructions

Important: RRC works only with Microsoft Internet Explorer. If you
are using a different web browser, MPC will load automatically.

Most users access RRC via Internet Explorer, while other users,
particularly those operating over a modem connection, access RRC
standalone. Both options are detailed in this guide.

Note: Modem use is not supported with Raritan's Dominion KX101.

RRC Minimum System Requirements

The minimum system requirements for the Raritan Remote Client are:

e CPU Speed: 1.0 GHz
e RAM: 512 Mbytes

Note: Running the client software on system configurations below either
of these specifications may impact performance and result in errors.

Installing and Opening Standalone RRC

Note: This step is optional. Devices can be accessed from a remote PC
either by installing RRC software or by opening RRC via a web browser.
Accessing Devices via a web browser does not require any software
installation on a remote PC.

This section lists the steps required to invoke RRC using standalone
software, which may be useful for accessing devices via modem or if you
wish to close firewall access to ports 80 and/or 443.

1. Launch your web browser and go to Raritan's website
(http://www.raritan.com/).

2. Click Support in the top navigation bar and then click Firmware
Upgrades in the left navigation panel (or type the URL
http://www.raritan.com/support/firmwareupgrades).

3. Scroll down the page until you see the appropriate product name and
click on it.

4. Locate the version of the standalone RRC client you are using. The
entry for the standalone RRC client is a .zip file which contains the
release notes and the installer for standalone RRC. Check the
release notes for the latest information.

5. Download the .zip file or simply click on the .zip file entry.
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Double-click on the installer executable in the .zip file and follow the
instructions in the InstallShield Wizard to complete the RRC
installation. Be sure to check the release notes for the latest
information and any release specific instructions.

Depending upon the configuration of your PC, the RRC installation
program may also automatically install DirectX and Microsoft
Foundation Class libraries (if they are required). If they are
installed, you will be asked to restart your PC after the installation.

A Raritan Remote Client icon will appear on your desktop after the
installation is complete. Click on this icon to open the standalone
RRC application.

The standalone application can be uninstalled using the Add or
Remove Programs function in the Windows Control Panel.

Note: You must uninstall the application before installing a new version
of standalone RRC.

=i=Raritan.
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Opening RRC from a Web Browser

Your device features web browser-access capabilities and can provide a
connection from any Windows-based, remote PC running Microsoft
Internet Explorer 6.0/7.0.

Security Settings
To access a device via the web, your web browser must be configured
appropriately on the Internet Explorer security settings tab. Specifically:

e "Download Signed ActiveX controls” should be set to either Enable
or Prompt.

e "Run ActiveX controls and plug-ins" should be set to either Enable or
Prompt.

Consult your Microsoft Internet Explorer documentation for additional
information.

Note: Microsoft Windows 2000, Microsoft Windows XP, and Microsoft
Windows 2003 restrict certain types of users from downloading and
running ActiveX controls and plug-ins regardless of the settings in
Internet Explorer. Consult your Microsoft Windows documentation for
more information.

» To open RRC:

1. Ensure that your browser security settings are configured
appropriately and type the IP address assigned to your device in the
URL field of your web browser. See the Initial Configuration section
in the device user guide for additional information on configuring IP
addresses.

a Raritan-Enterprize - Microsoft Internet Explorer

Eile Edit ‘“iew Fawortes Toolz Help |

POy ]t /152 166.50.1 72 ~] @6e

Note: Devices ship with the default IP address of 192.168.0.192.
Note that an IP address must be used. Host names are not currently
supported.
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You will be redirected to an HTTPS (128-bit) secure webpage so you
can open RRC.

2} Raritan Remote Client - Microsoft Internet Explorer

File Edit Miew Favortes Tool: Help

Addiess [ hitp://132.168.50.173 =l 6o

:léRur“’an,, Raritan Remote Client

» 1.21.2003 16:56:34.355 Raritan Remote Client loading...

=
|£j Done l_ l_ E |O Intemnet 4

2. Depending on your browser and its security configuration, you may
see any or all of the following dialogs asking you to confirm you want
to access and open an externally-provided application. Click Yes to
accept these prompts.

Security Alert | x| |
ri‘jl |nfarmation you exchange with this site cannot be viewed or

e changed by otherz. Howewer, there iz a problem with the zite'z
il
zecunty certificate.

The zecurity certificate waz izzued by a company vou hawve
not chozen to trust, Yiew the certificate to determine whether
yoL want ko kst the certifuing authority,

Q The zecurty certificate date iz walid.

The narme on the security certificate iz invalid ar does not
rmatch the name of the site

Do you want to proceed?

Wiew Certificate |

=i=Raritan.
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Internet Explorer |

FEQ Do pou want ko allow zoftware such az Actives controlz
?. and plug-inz to run?

Internet Explorer |

an thiz page which has been marked zafe for scripting.
Do pou want ko allows this?

& sonipt s accezsing 2ome zoftware [an Actives control]
:J.

Removing RRC from the Browser Cache

e Toremove RRC from your browser cache for any reason, follow the
standard procedure for your web browser software.

» Toremove cached files in Internet Explorer v6.0:

1. If you have used RRC recently, exit all instances of Internet Explorer
and restart Internet Explorer.

On the Internet Explorer Tools menu, choose Internet Options.

3. When the Internet Options dialog appears, click on the General
Settings tab and then click Delete Files.

Click on the Settings tab and then click View Objects.

Internet Explorer will display a list of cached objects. Select any
entries named “TeleControl Class,” “Raritan Console,” or “Power
Board” and delete them.
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Operation

Window Layout

MPC Interface

MPC functions are grouped into six general sections on the page. As a
standalone product or using a web browser, the MPC window contains

these main sections.

i

im

il

Rarttan M ulti-Platform Cliant
'E ed B
T I ‘

e o

G ot =

I .

=g My Conpite

&
(T

1oLt Ak

st | | [ B T2
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RRC Interface

The RRC window is almost identical to the MPC window.

Welcome 1o QuickTima

Els Ect Movie Favorbes ‘window Help

Iy Doouments  Ad-Anere 5 g
Personal

@

i
. Get connected to the Internet
sf - .
\ foryour guide to the best
in QuickTime content.

QuickTime
iaenet  Netscape 7.1 Ay 1
Exphorer B v e iy el )
[ . 1

£ A £ £ @

‘ﬁ.‘?—“ FI=IT =1 i

P
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Navigator

The navigator provides a tree view of every known Raritan device. From
this panel, you can access all Raritan networked devices for which a
connection profile exists and/or all Raritan devices automatically
identified on the network.

Note: Automatic Raritan device identification uses the UDP protocol and
will typically identify all Raritan devices on your subnet. Network
administrators rarely allow UDP broadcasts to function outside of a
subnet. Automatic Raritan device identification will find only those
Raritan devices that are configured to use the default TCP Port (5000) or
another broadcast port, which is defined on the Advanced tab of the
Options dialog (choose Tools > Options to access the Options dialog).

E_Q Raritan Devices

..... {4 B ENG_TR364 [192.168.53.183]

{1 B Ewa [192.168.53.110] {
[ B Jackie-101-P52 [192,168.52.94]

----- {4 B Jackies [192.165.52.95]

----- @ 'S Dominion K5 [192.168.51.154]

- @ B IP-Reach [192.168.0,192]

@ E‘I TechSupport-IPR [192.163.51.207]
----- @ % Daminion K5y [192,168.51,202] ’
..... @ S K5%-223 [192.168.51.223] 3
- B KS¥440 [192,168.51.157)

- B kx116-112 [192.168.51.167]
----- @ S DKx [192.168.51,204]
----- @ 'Sl K432 [192.168.51.185]

G.I % USTIF‘ T%LQEJ?%J EEIS]

-\-\.

Device Naming in the MPC Navigator

In MPC, devices are named according to the Manager Name field on the
Manager's Network Configuration page. Dominion devices are named
according to the Device Name field on the Dominion Console Network
Settings page.

Devices in the RRC Navigator

In RRC, profiled devices are listed in the Navigator according to the data
in the Description field of the device's profile. Automatically-identified
devices will be identified according to the name assigned to them in that
device's network configuration setting.

=i=Raritan.
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Device Ports in the Navigator

For each device to which you are connected, you are able to expand the
tree associated with it to see each device port to which you have access.
Ports with a green icon indicate that you are connected to that port. The
port that is bolded in the Navigator indicates that it is the port currently
displayed (active) in the remote desktop area of the application.

If no name is assigned to a port, by default it is listed in the Navigator as
'‘Unnamed' for Generation 1 devices and, for the KX II, as
Dominion_KX2_PortN (N = port number).

Depending on the maximum number of KVM sessions the device can
handle at once, if all device ports to which you are connecting are
already occupied, an alert message appears and you must wait until one
of the ports is available in order to connect.

Navigator Icons

Each device in the Navigator is assigned two icons. One icon represents
the device's connection profile and the other icon represents its network
status. A connection profile is generally created by a user in order to
store personalized information about specific devices (see Connection
Profiles (on page 74) for additional information). The connection status
indicates the current status of the device.

Device Connection Profile Icons (Left Icon)

Icon Description

O Profiled - A network connection profile exists for this
device.

Modem Profile - A modem connection profile exists for
this device.

@ Not Profiled - The device was found on the network but

a connection profile does not exist for it.

Device Network Status Icons (Right Icon)
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Icon

L
|
=

Description

Connected (green) - You are currently authenticated
and connected to this device.

Available (black) - This device is currently available on
the network but you are not currently connected to it.

Unavailable - A profile exists for this device but it is not
currently available on the network. (Note that all devices
to which you are not currently connected and that have
modem profiles will use this icon.)

Port Connection Status Icons

For each server port listed in the Navigator, the following icons can be
associated with it depending on its status:

Icon

e
=y
Nl 1

=

Description
Connected

Available for connection.

Unavailable (either no device is connected or access is
blocked).

In use by another user (may be unavailable depending
on permissions).

Customizing the Navigator

Use specific tools in the toolbar to customize some Navigator attributes:
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Icon Action

Display/Hide
Navigator

Refresh Navigator

Q Browse
Discovered
Devices

MPC Navigator Tabs

Description

You can also select Navigator in the

View menu to toggle between displaying

and hiding the Navigator.

Updates the device status information
displayed in the Navigator.

When enabled, Show Discovered
Devices will display devices that are
“not profiled” but have been found on
the network. This option can also be
enabled by choosing View > Show >
Discovered Devices.

Note: The Browse Discovered Devices
option is the only method of connecting
to a Raritan device configured to use a
DHCP IP address.

MPC tabs at the base of its Navigator pane. These tabs allow you to
change how you display devices. Click the View By Name tab to sort the
list alphabetically by name, click the View By IP tab to sort the list
numerically by IP address, or click on the View by Host Name tab to sort
the list alphabetically by display name.

View By Name | ey By Ip
Wiew By Host Marme =

TTRTTOWTT L2, L00, -\_lLluJ.f.Ju
Connecking..,
[Unknown 192,162, 50.12]:
Connected

[Unkrnown 192,168.50.12]: Login

cormplete,

*]
\“hw \_,, e

L 3 1314;-‘@&"1.’» h%\“'.'f'"\v..’m& ;

These tabs are available only in the MPC interface.
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Navigator Display and Sort Options

To better organize your view of all ports, use the Show and Sort options
in the View menu. Note that you do not need an open connection to a
target to show and sort targets in the Navigation panel.

Showing Ports

e Discovered Devices - Shows or hides discovered devices from the
Navigator view. You will not see broadcast messages when this
option is disabled (not selected).

e Unassigned Channels - Shows or hides channels with no assigned
targets. Note that the default for Generation 1 (G1) devices is to
show unassigned channels (option is enabled), whereas the default
is to hide unassigned channels (option is disabled) for Generation 2
(G2) devices.

e Tools - Shows or hides the Admin and Diagnostic ports.

Note: These settings are saved from session to session.

Sorting Ports

Use the Sort options on the View menu to organize port information. You
are able to sort ports by channel number, channel name, or channel
status.

Connection USE Profile Serizl Keyboard Video Mouse Virkual Media Tools [Wiew Window Help

o) el eles || S8 ol s

g ¥ 2tandard Toolbar

¥ Connected Server(s) Toolbar

[V status Bar

¥ Havigator

MMessage

Show ]

Sort M ¥ channel
Full Screen [d Hame
[0 scale video [0 status

e Channel Number - When sorted by channel (View > Sort > Channel),
ports are listed numerically.
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- B Dnnininneky [ 97, 157.51.54]
& S Doniniorrkx [£92,158,51,1847
=10 SUN Solaris
CgEl 3y inz000
»Mac 05x
(10

JEve
1 tlice
1 Charley
» Sarbera

A= g Zlen

Name - When sorted by name (View > Sort > Name), port names are
sorted alphanumerically within each group.

. o S Dominion-Kx [192.168.51,34]
[] & 2= Dominion-k¥ [192.168.51,184]

-4 arthur: 25

- H=W Darbara: 0
il 26

4= Charlene: 27
~N=W Charley: 7
~AE Dy 5

@ Dave 2: 15
LN Dave 0003 16
A neharahe 7R

-4 Eller: 9
-\ Evan: 30

i @ Framcine: 21

Status - When sorted by status (View > Sort > Status), ports are
sorted in the following order:

= Active Channels
= Busy Channels

=  Available Devices
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= Unavailable Devices

----- @ % Dominion-Kx [192,168.51.34]
= @ ﬁ Lo ks [192,165.51.154]
..... =, sUN Salaris: 1

..... 7m8 \Win2000; 2

A= alce: b

- Am apthr: 25

~N=¥ Barbara: &

44 Bill: 26

@ Charlena: 27

=¥ Charley: 7

@ Dave: 5

@ Loz 2t 15

4= Dave 0003: 16

@ Debarah: 28

@ Elleii: 9

- AE Eyan: 30

Note: Sorting ports does not apply to KX [I-101.

Toolbars

Standard Toolbar

The Standard toolbar provides one-click access to the most
frequently-used commands.

> To display the Standard toolbar:
e Choose View > Standard Toolbar.

Following is a list of the buttons in the standard toolbar as well as a
description of the action performed once the buttons are selected.
Additionally, if there are menu options or shortcut menu options that will
perform the same task, they are listed, too.

Button Button Description
Name
| New Profile  Creates a new Navigator entry for a

Raritan device.

Same result as choosing Connection >
New Profile in the menu.

e
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Button Button
Name

? Connection

= - .

Properties

% Video
Settings
Color

'E' Calibration

Ei;" Target
- Screenshot

Synchronize
Mouse

Refresh
Screen

== Auto-sense
s Video
Settings

i
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Description

Opens the Modify Connection Properties
dialog from which you can manually adjust
bandwidth options (such as connection
speed, color depth, and so forth).

Same as choosing Connection >
Properties or choosing Connection
Properties on the shortcut menu, which is
opened by pressing Ctrl+Left Alt+M.

Opens the Video Settings dialog, allowing
you to manually adjust video conversion
parameters.

Same as choosing Video > Video Settings
or choosing Video Settings on the shortcut
menu, which is opened by pressing
Ctrl+Left Alt+M.

Adjusts color settings to reduce excess
color noise.

Same as choosing Video > Color Calibrate.

Click to take a screenshot of the target
server and save it to a file of your
choosing.

In dual-mouse mode, forces realignment of
the target server mouse pointer with the
mouse pointer.

Same as choosing Mouse > Synchronize
Mouse or choosing Synchronize Mouse on
the shortcut menu, which is opened by
pressing Ctrl+Left Alt+M.

Forces a refresh of the video screen.

Same as choosing Video > Refresh Screen
or choosing Refresh Screen on the
shortcut menu, which is opened by
pressing Ctrl+Left Alt+M.

Forces a refresh of the video settings
(resolution, refresh rate).

Same as choosing Video > Auto-sense
Video Settings.
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Button

Eil:

Button
Name
Enter
On-Screen
Menu

Exit
On-Screen
Menu

Send
Ctrl+Alt+Del

Single Cursor
Mode

Full Screen

Mode

Scaling

Show/Hide
Navigator

Description

Not applicable for the device. Used by the
application with other Raritan products.

Same as choosing Keyboard > Enter
On-Screen Menu.

Not applicable for IP-Reach or Dominion.
Used by the application with other Raritan
products.

Alternatively, select Esc on the keyboard.
Same as choosing Keyboard > Exit
On-Screen Menu.

Note: This function is not available on the
KSX 1.

Sends a Ctrl+Alt+Del hot key combination
to the target server.

Same as choosing Keyboard > Send
Ctrl+Alt+Del.

Starts Single Cursor mode in which the
local mouse pointer no longer appears
onscreen.

Same as choosing Mouse > Single Cursor
Mode. Press Ctrl+Alt+X to exit this mode.
Alternatively, choose Single/Double Cursor
from the shortcut menu, which is opened
by pressing Ctrl+Left Alt+M.

Maximizes the screen real estate to view
the target server desktop.

Same as choosing View > Target Screen
Resolution (in MPC) or Full Screen (in
RRC). Alternatively, press Ctrl+Left Alt+M
to open the shortcut menu and then
choose Full/Normal Screen or press the F
key on your keyboard.

Increases or reduces the target video size
S0 you can view the entire contents of the
target server window without using the
scroll bar.

Toggles the Navigator panel between
visible and hidden.

Same as choosing View > Navigator.

=i=Raritan.
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Button Button

Name
Refresh
Navigator
S Show/Hide
Browse All
Devices
w About
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Description

Forces a refresh of the data displayed in
the Navigator.

Toggles between displaying and not
displaying Raritan devices in the Navigator
that are automatically identified on the
network and that do not have
preconfigured profiles associated with
them.

Displays the application version
information.

Same as choosing Help in the menu bar.

MPC Connected Server(s) Toolbar

The Connected Server(s) toolbar is comprised of a button for each
connected target server port, thus enabling quick access to connected
targets. When you connect to a port, a button corresponding to that port
is added to the toolbar and labeled with the name of the port.
Conversely, when you disconnect from a port, the corresponding button
is removed from the toolbar.

Note: In Single Mouse mode, the Connected Server(s) Toolbar appears
on the target but cannot be accessed.

By default, the Connected Server(s) toolbar is enabled (visible). To
disable it, deselect Connected Server(s) Toolbar in the View menu.
Buttons corresponding to windows that do not support Full Screen mode
are not shown in the toolbar. For example, serial ports, generation one
(G1) admin ports, and G1 diagnostic ports will not be displayed in the
toolbar in Full Screen mode.

While in Full Screen mode, you are able to view the Connected Server(s)
toolbar by hovering your mouse over the top of the screen. To use this
feature, the Connected Servers Toolbar option must be selected in the

View menu.

‘ 2 C3'D--.| ﬁﬁd... |§ wmz...| =) chan... I
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> To display the Connected Server(s) toolbar (when not already
visible):

e Choose View > Connected Server(s) Toolbar.

> To view the window for a target server:

e Click the button that corresponds to the appropriate connected target
server you want to view. The window for the corresponding target
server is displayed and the button for the selected port is highlighted.
In Full Screen mode, note that this action is window swapping, not
video switching.

When you click a button that is already highlighted, the corresponding
window is minimized. If you click that button again, the window is brought
forward and maximized.

Status Bars

MPC Status Bar

The status bar displays session information about your connection to a
Raritan device. This information includes:

Icon Session Description
information

z Concurrent Indicates that multiple remote users are
connections currently connected to the same target
indicator server on the device.

One icon indicates a single user is
connected, and two icons indicates two or
more users are connected.

Concurrent connection ability can be set
globally under PC share mode on the
Manager Security Settings page or set per
individual user in the Concurrent Access
Mode setting on the Manager User
Account Settings page. For the device,
concurrent connection ability can be set
using the PC Share Mode option in the
Security Settings page: PC-Share permits
concurrent access and Private limits
server access to one user at a time.

o0 =i=Raritan.
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Icon Session Description

information
CAP, Lock key Indicates the status of the current target
NUM, indicators KVM Server, in respect to the activation of
SCRL the Caps-Lock, Num-Lock, and

Scroll-Lock keys. If these keys are
enabled on the target server being
viewed, this affirmative status will be
reflected on the status bar.

Note: If a light is used on your keyboard to indicate the Scroll Lock, Num
Lock, and Caps Lock key is active, it may or may not be in sync with the
lock key indicator status displayed on the status bar. See the status bar
as your guide if this occurs.

RRC Status Bar

The status bar displays session information about your connection to a
Raritan device. This information includes:

[ Path 3 (KM Part 3) [ & T 6 Cap UM [5 CFEL/

O 000 &

Diagram Session Description

key information

@ Video sensing Indicates when video sensing occurs
status/path during connections to target KVM server
indicator ports.

@ Bandwidth Indicates how much of your total available
usage indicator  bandwidth is currently being used. The

connection speed setting determines total
available bandwidth.

This setting is defined on the
Compression tab of the Connection
Properties dialog, which is accessed by
choosing Connection > Properties, or
pressing Ctrl+Left Alt+ M and then
choosing Connection Properties.
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Diagram Session Description

key information

@ Security Indicates whether the current remote
indicator connection is protected by encryption.

Encryption requirements are set during
configuration of your Raritan device.

When a device is configured for no
encryption or SSL authentication, the
Security Indicator is represented on the
status bar by an open lock icon.

When SSL authentication, data
encryption, or SSL encryption is applied,
the security indicator is represented on
the status bar by a closed lock.

@ Concurrent Indicates that multiple remote users are
connections currently connected to the same target
indicator server on the device.

One icon indicates a single user is
connected, and two icons indicates two or
more users are connected.

Concurrent connection ability can be set
globally under PC share mode on the
Manager Security Settings page or set per
individual user in the Concurrent Access
Mode setting on the Manager User
Account Settings page. For the device,
concurrent connection ability can be set
using the PC Share Mode option in the
Security Settings page: PC-Share permits
concurrent access and Private limits
server access to one user at a time.

@ Lock key Indicates the status of the current target
indicators KVM Server, in respect to the activation of
the Caps-Lock, Num-Lock, and
Scroll-Lock keys. If these keys are
enabled on the target server being
viewed, this affirmative status will be
reflected on the status bar.

Note: If a light is used on your keyboard to indicate the Scroll Lock, Num
Lock, and Caps Lock key is active, it may or may not be in sync with the
lock key indicator status displayed on the status bar. See the status bar

as your guide if this occurs.
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Screen Modes

Besides a standard view, full screen view and a scaling option are
available. These options increase the remote desktop area and make
viewing the target video easier.

MPC Full Screen Mode

Full Screen mode provides you with the ability to view the target server
desktop in Full Screen mode, which removes all toolbars from view.

Activate Full Screen mode once you are connected to a target by doing
one of the following:

e Click the Full Screen button E in the toolbar and then click OK in
the confirmation message that appears.

e Choose View > Full Screen and then click OK in the confirmation
message that appears.

e Press Ctrl+Left Alt+M to open the shortcut menu. Next, press the F
key on your keyboard or use your mouse to choose Full/Normal
Screen. Click OK in the confirmation message that appears.

== Raritan.

ZullfHormal Saeen

Auto Senze

Zalibrate Calor

Zonrecticn Information

Zonreckicn Properties

Wideo Settings

Refresh Screen

sumchramize Mausze

ZinglefDouble cursar

Sand Ctrltalt+Dal

conreck Drive..,

Tonrec CO-R2MIISS Inmags..,

Send Ctrl+Aalt+r

Zancel (E=c)
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Fo. Srw...[

To exit Full Screen mode, use the shortcut menu or click the Close icon

il that appears at the top right of the page when you hover your mouse
along the top of the screen.

Note: The Ctrl+Left Alt+M key combination does not work for certain
target servers if you are running JRE 1.5.0_01. To return from full page
mode, use Alt+Tab and choose MPC.

While in Full Screen mode, you are able to view the Connect Server
toolbar by hovering your mouse over the top of the screen. To use this
feature, the Connected Servers Toolbar option must be selected in the
View menu.

Additionally, while in Full Screen mode, your monitor's resolution may be
adjusted to match the resolution of the target server (provided your
graphics system supports it). If your graphics system does not support
the resolution of the target system, you will be unable to activate Full
Screen mode and a message will appear requesting that you change
your video resolutions first.

Tip: To view the video resolutions your system supports in a Windows
environment, access your computer's Control Panel from the Windows
Start menu, double-click Display, and click the Settings tab.

il |

=i=Raritan.
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RRC Full Screen Mode

Full screen mode removes the surrounding RRC graphical interface and
your local desktop area, filling your screen with the video from the target
server. Your screen's resolution will be adjusted to match the resolution
of the target server (provided your graphics system supports it). If your
graphics system does not support the resolution of the target system,
you will be unable to activate full screen mode and a message will
appear requesting that you change your video resolutions first.

Note: To view the video resolutions your system supports in a Windows
environment, access your computer's Control Panel from the Windows
Start menu, double-click on Display, and click on the Settings tab.

Activate full screen mode in one of the following ways once you are
connected to a target:

e Click the Full Screen icon = in the toolbar and then click OK in the
confirmation message that appears.

e Choose View > Full Screen and then click OK in the confirmation
message that appears.

e Press Ctrl+Left Alt+M to open the shortcut menu. Next, press the F
key on your keyboard or use your mouse to choose Full/Normal
Screen. Click OK in the confirmation message that appears.
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MIFFER.PCF

Msat| | AEHAZWJBs €D 7 [EBNYEAET & 325PM
MPC Scaling

Scaling your target window size allows you to view the entire contents of
the target server window. This feature increases or reduces the size of
the target video to fit the window size and maintains the aspect ratio.
This allows you to see the entire target server desktop while in standard
view.

> To activate Scaling, do one of the following:
e Choose View > Scale Video.

Connecion  USE Profile Keyboard Wideo Mouse Wirtual Media Tools |Wiew Window Help

; | = -;1_; el E ‘ J w1 |j ¥ Standard Toolbar
m ? @‘ E‘E/J‘ ‘5’ ' @ J_L E‘“J g M Connected Serveris) Toolbar

M status Bar

¥ Havigator

M Message
Show ]
Sort ]

Full Screen

[0 scale video

B
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e Click the Scaling button @ on the toolbar.

e To exit this mode and return the target window to its previous size,
deselect Scale Video on the View menu or click the Scaling button
once again.

Note: Enabling Scale Video will scale the complete target video image to
fit the remote desktop area as it grows or shrinks. You can combine this
setting with target screen resolution for a full page affect on targets with
a higher resolution than your desktop.

RRC Scaling

Scaling your target window size allows you to view the entire contents of
the target server window. This feature increases or reduces the size of
the target video to fit the window size and maintains the aspect ratio.
This allows you to see the entire target server desktop while in standard
view.

To activate Scale Video mode, do one of the following:

e Choose View > Scale.

T Conmection  Keyboard Wideo Mouse Tools NIEER window  Help
EMC L &= S| v Toolbar
w Status Bar
w Mavigaktar
Show 3

Sart 3

Full Screen

El

e Click the Scaling button == on the toolbar.

To exit this mode and return the target window to its previous size,
choose Scale on the View menu or click the Scaling button once again.

Note: Enabling Scale Video will scale the complete target video image to
fit the remote desktop area as it grows or shrinks. You can combine this
setting with target screen resolution for a full page affect on targets with
a higher resolution than your desktop.
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Auto-Scroll

The auto-scroll feature automatically scrolls the video display in the
direction of the cursor as the cursor approaches the edge of the display.
A thin border appears around the perimeter of the remote desktop area
to indicate the function is on. When enabled, if you see scroll bars and
then move the cursor onto the border, the page will automatically scroll in
the appropriate direction.

The scroll border is activated by selecting Show Scroll Borders in the
Options dialog, which is accessed by choosing Tools > Options.

Connection Profiles

Connection profiles store important information about your Raritan
device such as the IP address, custom TCP ports, preferred
compression settings, and custom security keys. A profile is required to
access devices outside your subnet and to access devices using a
dial-up connection.

Through profiles, you can set up personalized connections. These
profiles are not shared among other users.

The information collected when creating a new connection profile will
differ based on Generation 1 and Generation 2 devices.

Tip: If your Raritan device is configured to use a custom TCP port or a
group security key, first create a connection profile so that you can
access the device.

Creating, Modifying and Deleting Profiles in MPC

> To create a profile:
There are two ways to create a profile:

= For automatically discovered devices, right-click the device name
in the Navigator and choose Add Profile from the shortcut menu.

= For other devices, choose Connection > New Profile.

The Add Connection dialog appears. Options are organized into
three tabs.

Note: The Connection and Security tabs are not available for
Generation 2 devices.

Connect tab

1. On the Connect tab, type a meaningful description of the device in
the Description field. This description identifies the Raritan device in
the Navigator.
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2. From the Product drop-down, choose the Raritan product you are
using.
TCP/IP connections
Select the type of connection from the Connection Type drop-down.
a. If TCP/IP Connection is selected for a LAN/WAN connection,
complete the information in the "Find Raritan device By" section:
= Type the IP address assigned to your Raritan device.
= Type the name assigned to your Raritan device during initial
setup.
= Type the Domain Name Server (DNS) name. Use this option if
you use a DNS server to resolve a DNS name to the IP address
assigned to your Raritan device.
Add Connection E|
Connedk I Compression | Security |
Dezeriphion: |
Product: |D0mini0n KH §1 |L|
Connedion Type: |[TCRIP Connedion |L|
Find Raritan dewvice By:
@) IP Address |
D Cevice Mame |
O Host Marme |
Use Default Port Murnber Port Hurmber: |
[s114 Cancel

Dial-up connections

a.

Select Dial Up Connection from the Connection Type drop-down
for a direct analog modem connection to the Raritan device.
Type the parameters that should be used to establish a
connection.

Enter the phone number for the dial-up connection. Remember to
include any additional codes that should be dialed to establish a
connection, such as country codes, area codes, or outside line
access codes.

Select the modem (as configured in Windows) from the
drop-down list that will be used to dial and connect to your
Raritan device.
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Note: For security reasons, you must use the MPC standalone client
if you require modem access. Further, one modem on a client PC
can be used for only one device connection.

Add Connection E|

Connect | Compression | Security |

Dezecription: |

Product: |D0mini0n Ki Gl

L L

Connecion Type: |Dial Up Connection

Phone Mumber; |

Modem: |Cone><ant HDw& D110 MDC V.92 Modem v|

Use Default Port Nurmber FPort Humber: |

=14 Cancel

Select the Use Default Port Number checkbox to use the default port
number (5000). For TCP Ports, devices are automatically configured
to use TCP Port 5000 when communicating with the client.

If you do not want to use the default port number, deselect the
checkbox and type the port number in the Port Number field.

Compression Tab

1.

Set the Connection Speed.

Use this setting to manually adjust the connection speed to
accommodate bandwidth constraints. Devices can automatically
detect available bandwidth and not limit bandwidth use. However,
you can also adjust this usage according to your needs. Depending
on the Raritan device in use, different options may be available:

= Auto Detect

= 1G Ethernet

= 100mb Ethernet

= 10mb Ethernet

= 1.5mb (Max DSL/T1)

= 1mb (Fast DSL/T1)

= 512 kb (Medium DSL/T1)
= 384 kb (Slow DSL/T1)

= 256 kb (Cable)

= 128 kb (Dual ISDN)

=i=Raritan.
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= 56 kb (ISP Modem)
= 33 kb (Fast Modem)
= 24 kb (Slow Modem)

Note: Raritan recommends that if you are connecting to the via
modem, you set the connection speed to 33kb.

Set the Color Depth.

Devices can dynamically adapt the color depth transmitted to remote
users in order to maximize usability in all bandwidths. Select from
among the options in the drop-down list. Depending on the Raritan
device in use, different options may be available:

= 15-bit RGB Color
= 8-bit RGB Color

= 4-bit Color
= 4-bit Gray
= 3-bit Gray
= 2-bit Gray

= Black and White

Important: For most administrative tasks (server monitoring,
reconfiguring, and so forth), administrators do not require the full
24-bit or 32-bit color spectrum made available by most video
graphics cards. Attempting to transmit such high color depths wastes
network bandwidth.

Note: If you are connecting to the via a modem, Raritan
recommends setting the color depth to 4-bit gray.

Select Progressive Update to increase the usability in constrained
bandwidth environments. When Progressive Update is enabled, the
device initially sends an image of the remote desktop at lower color
depths. Higher color depth images are provided as the bandwidth
allows.

Note: When Color Depth is set to Auto Select Color (default),
Progressive Update is automatic. The device will enable/disable
Progressive Update as required, disabling it for fast connections and
enabling it for slow connections.

Selecting the Internet Flow Control checkbox ensures that packets
transmitted by the device are received and reconstructed by the
client application in the correct order. This is useful when using a
device over an unpredictable public WAN (particularly in international
scenarios).
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Use the slider to select the desired level of video Smoothing (15-bit
mode only). The level determines how aggressively to blend page
regions with small color variation into a single, smooth color.
Smoothing improves the appearance of the target video by reducing
the video noise that is displayed.

Select "Frames per second". This setting instructs MPC on how often
to redraw the video display of the target. This only affects the client
display behavior and has no bearing on the data rate of the video
being sent to the client. Setting this option higher makes the video
appear smoother but also requires more processing power.

Add Connection E|
| Connect Compression S ecurity
Connection Speed: |)9_n._|_tq bgtet_:t- |j
Color Depth: |Aut0 Select Calor |j
[ progressive Update
[ Internet Flow Contral
Smoothing: E: Hilgh
Frarmes per SECDI‘Id
@ S fps O 10 fps O 20 fps
| (814 Cancel
Security Tab
1. Enter the private security key in the Private Key field if your device is
configured to use a private security key. Entering a security key
allows you to gain the authorization required to initiate a connection
to that device.
2. Retype the private security key in the Confirm Private Key field to

ensure no typographical errors were made.

=i=Raritan.
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3. Click OK to create the connection profile.

X

Add Connection

| Connect | Compression| Security |

Private Key: I

Confirrm Private Key: |

he private key MUST rmatch the private key set by the Adrministrator
or connections will be denied,

|_ok || cancel
» To modify a profile:
1. Select the device in the Navigator panel and right-click it.
2. Choose Modify Profile. The Modify Connection dialog appears.
3. Update the fields as appropriate.
4. Click OK.
> To delete a profile:
1. Select the device with a profile in the Navigator and right-click it.
2. Choose Delete Profile.
3. When prompted to confirm the deletion, click Yes to delete the profile

for this device or click No to return to the application without deleting.

Note: The only supports modem connections to the Administrative
functions in MPC. Port functions are not supported via modem.

Creating, Modifying and Deleting Profiles in MPC - Generation 2 Devices

> To create a profile:
1. There are two ways to create a profile:

= For automatically discovered devices, right-click the device name
in the Navigator and choose Add Profile from the shortcut menu.

= For other devices, choose Connection > New Profile.

The Add Connection dialog appears. Options are organized into
three tabs.
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Note: The Connection and Security tabs are not available for
Generation 2 devices.

2. Onthe Connect tab, type a meaningful description of the device in
the Description field. This description identifies the Raritan device in
the Navigator.

3. From the Product drop-down, choose the Raritan product you are
using.

4. Select the type of connection from the Connection Type drop-down.

TCP/IP connections

a.

Add Connection

Connect | o EEEsEiEn | Shecupity |

Connection Type:
Find Raritan device By:
8 IP Address |

O Device Mame |

O Host Marme |

Use Default Part Number Fort Hurnbers |

If TCP/IP Connection is selected for a LAN/WAN connection,
complete the information in the "Find Raritan device By" section:

Type the IP address assigned to your Raritan device.

Type the name assigned to your Raritan device during initial
setup.

Type the Domain Name Server (DNS) name. Use this option if
you use a DNS server to resolve a DNS name to the IP address
assigned to your Raritan device.

X

Description: |Deuice A

Froduct:

Dorninion KX G2

KRIKD

TCR/IP Connection

Ok Cancel

Dial-up connection

a.

Select Dial Up Connection from the Connection Type drop-down
for a direct analog modem connection to the Raritan device.
Type the parameters that should be used to establish a
connection.

Enter the phone number for the dial-up connection. Remember to
include any additional codes that should be dialed to establish a
connection, such as country codes, area codes, or outside line
access codes.

=i=Raritan.
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= Select the modem (as configured in Windows) from the
drop-down list that will be used to dial and connect to your
Raritan device.

Note: For security reasons, you must use the MPC standalone client
if you require modem access. Further, one modem on a client PC
can be used for only one device connection.

Add Connection g|
Connect | GO E T EESi RN | Security |
Description: |
FProduct: |D0mini0n Kx G2 ILI
Connedion Type: [Dial Up Connection |:|
Fhone Murmber: |
Maoderm: |C0ne><ant HOA D110 MDC V.92 Modem |L|
Use Default Port Hurmber Port Humber: |
(=18 Cancel

5. Select the Use Default Port Number checkbox to use the default port
number (5000). For TCP Ports, devices are automatically configured
to use TCP Port 5000 when communicating with the client.

If you do not want to use the default port number, deselect the
checkbox and type the port number in the Port Number field.

Note: Dial-up is not supported in KX 11-101.

» To modify a profile:

1. Select the device in the Navigator panel and right-click it.

2. Choose Modify Profile. The Modify Connection dialog appears.

3. Update the fields as appropriate.

4. Click OK.

> To delete a profile:

1. Select the device with a profile in the Navigator and right-click it.

2. Choose Delete Profile.

3. When prompted to confirm the deletion, click Yes to delete the profile

for this device or click No to return to the application without deleting.
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Creating, Modifying and Deleting Profiles in RRC

» To create a profile:
1. There are two ways to create a profile:

= For automatically discovered devices, right-click the device name
in the Navigator and choose Add Profile from the shortcut menu.

= For other devices, choose Connection > New Profile.

The Add Connection dialog appears. Options are organized into
three tabs.

Note: The Connection and Security tabs are not available for
Generation 2 devices.

Add Connection @

Catnect ] I:Dmpressicun] EEcuritﬂ

Description ]l

Connection Tepe 1Dial Il p Connection j

FPhore Murmnber ]

Moder:  |Conesant HDA D110 MDC Y. 52 Modem |

W Uze Default Port Mumber

ok | Cancel

Connect Tab

On the Connect tab, type a meaningful description of the device in the
Description field. This description identifies the Raritan device in the
Navigator.

1. Select Dial Up Connection from the Connection Type drop-down for
a direct analog modem connection to the Raritan device. Type the
parameters that MPC or RRC should use to establish a connection.
Dial up connection does not apply to Generation 2 (G2) or KX101.
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= Enter the phone number for the dial-up connection. Remember to
include any additional codes that should be dialed to establish a
connection, such as country codes, area codes, or outside line
access codes.

= Select the modem (as configured in Windows) from the
drop-down list that will be used to dial and connect to your
Raritan device.

Note: For security reasons, you must use the MPC standalone client
if you require modem access. Further, one modem on a client PC
can be used for only one device connection.

Select the Use Default Port Number checkbox to use the default port
number (5000). For TCP Ports, devices are automatically configured
to use TCP Port 5000 when communicating with the client.

If you do not want to use the default port number, deselect the
checkbox and type the port number in the Port Number field.

Compression Tab

1.

Set the Connection Speed.

Use this setting to manually adjust the connection speed to
accommodate bandwidth constraints. Devices can automatically
detect available bandwidth and not limit bandwidth use. However,
you can also adjust this usage according to your needs. Depending
on the Raritan device in use, different options may be available:

= Auto Detect

= 1G Ethernet

= 100mb Ethernet

= 10mb Ethernet

*  1.5mb (Max DSL/T1)
= 1mb (Fast DSL/T1)

» 512 kb (Medium DSL/T1)
* 384 kb (Slow DSL/T1)
= 256 kb (Cable)

= 128 kb (Dual ISDN)

= 56 kb (ISP Modem)

= 33 kb (Fast Modem)

= 24 kb (Slow Modem)
Set the Color Depth.
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Devices can dynamically adapt the color depth transmitted to remote
users in order to maximize usability in all bandwidths. Select from
among the options in the drop-down list. Depending on the Raritan
device in use, different options may be available:

= 15-bit RGB Color
= 8-bit RGB Color

= 4-bit Color
= 4-bit Gray
= 3-bit Gray
= 2-bit Gray

= Black and White

Important: For most administrative tasks (server monitoring,
reconfiguring, and so forth), administrators do not require the full
24-bit or 32-bit color spectrum made available by most video
graphics cards. Attempting to transmit such high color depths wastes
network bandwidth.

Select Progressive Update to increase the usability in constrained
bandwidth environments. When Progressive Update is enabled, the
device initially sends an image of the remote desktop at lower color
depths. Higher color depth images are provided as the bandwidth
allows.

Note: When Color Depth is set to Auto Select Color (default),
Progressive Update is automatic. The device will enable/disable
Progressive Update as required, disabling it for fast connections and
enabling it for slow connections.

Selecting the Internet Flow Control checkbox ensures that packets
transmitted by the device are received and reconstructed by the
client application in the correct order. This is useful when using a
device over an unpredictable public WAN (particularly in international
scenarios).
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Use the slider to select the desired level of video Smoothing (15-bit
mode only). The level determines how aggressively to blend page
regions with small color variation into a single, smooth color.

Smoothing improves the appearance of the target video by reducing
the video noise that is displayed.

Add Connection

Crnnert  Compression ! !:.F:nurilyl
Connection Speed:
Color Depth: |.-’-‘-.ut-:| Select Color :J
[T Prooressive pdats
[ Intemet Flow Contral
S moothing fE -—-_; M ax
OF | Cancel
Security Tab
1. Enter the private security key in the Private Key field if your device is
configured to use a private security key. Entering a security key
allows you to gain the authorization required to initiate a connection
to that device.
2. Retype the private security key in the Confirm Private Key field to

ensure no typographical errors were made.
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3. Click OK to create the connection profile.

Add Connection

X

Eunnect] Compression  Security l

Private Key: |

Confirm Private Kew |

The private key MUST match the private
key zet by the adminiztrator or connections
will be denied.

k. | Cancel

=i=Raritan.



=i=Raritan.

Chapter 3: Multi-Platform Client and Raritan Remote Client

Establishing a New Connection

Note: Depending on your version of the JRE, you might receive a
certificate message when using the standalone application to access a
Dominion device. You have to accept the certificate in order to establish
the connection.

To connect to a device, double-click the device's icon in the Navigator,
then type your user name and password to connect. You can also
right-click the device name in the Navigator and select New Connection.

Note: The default device login user name is admin and the default
password is raritan. You have administrative privileges using these login
credentials.

If you do not see an icon for your device in the Navigator, follow the
instructions on creating new profiles, which is available in this section.

If you are having problems connecting to a device, be sure to check the
following:

e Username - Raritan usernames are not case-sensitive.
e Password - Raritan passwords are case-sensitive.

e TCP Port- If you have configured your device to use a non-default
TCP Port, this information must be entered into its connection profile.

e Firewall Settings - If you are accessing a device through a firewall,
that firewall must be configured to allow two-way communication on
TCP Port 5000 (or the custom TCP Port to which your device has
been configured).

e Security Key - If you have configured your device to require a
group security key, that key must be entered into the device's
connection profile.

Note: If you are running MPC on Internet Explorer with both a Microsoft
firewall and a non-Microsoft firewall utility installed, IE will display a
message telling you that MPC is already running (even if it is not in fact
running). To avoid this, deactivate one of your firewalls, or use a browser
such as Mozilla or Firefox.

Connection Information

» To obtain information about your connection:

e Choose Connection > Connection Info. The Connection Info dialog
appears.

87



88

Chapter 3: Multi-Platform Client and Raritan Remote Client

Generation 1 Devices

The following information is displayed about a current connection to

Generation 1 devices:

Connection
information

Device name
IP address
Port

Data in/second

Data out/second
FPS

Connect time
Horizontal resolution
Vertical resolution
Refresh rate
Protocol version

Oldest supported
version

Hardware version
Software version
Post code

Network flags

Security flags

Options
Frame grabber info
KME info

Serial Info

Video devices count

Description

The name of your device.
The IP address of your device.

The KVM Communication TCP/IP Port used to
access the target device.

Data rate in.

Data rate out.

The frames per second transmitted for video.
The duration of the connect time.

The page resolution horizontally.

The page resolution vertically.

How often the page is refreshed.

The RFB Protocol version.

The oldest supported version of the client
software.

0 - Obsolete
3 (Software version)
Power on self-test error code. 0 = no error.

A list of the various network options that have
been enabled or disabled such as DHCP,
dial-in, autodetection, and so on.

A list of the various security options that have
been enabled or disabled such as SSL
encryption, SNMP, and so on.

RFP and TR support enabled or disabled.
0 - not used

KME version number for systems that use the
KME.

Serial devices

Number of video devices detected.
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Connection Description
information

Serial devices count Number of serial devices detected.

Reserved 0 - not used

FPS* Frames per second

* Available only in MPC.

>

To copy this information:

Click Copy to Clipboard in the Connection Info dialog. The
information is now available to be pasted into the program of your
choice.

Generation 2 Devices

The following information is displayed about a current connection to
Generation 2 devices:

Connection Description

information

Device name The name of your device.

IP address The IP address of your device.

Port The KVM Communication TCP/IP Port used to
access the target device.

Data in/second Data rate in.

Data out/second Data rate out.

FPS The frames per second transmitted for video.

Connect time The duration of the connect time.

Horizontal resolution The page resolution horizontally.

Vertical resolution The page resolution vertically.

Refresh rate How often the page is refreshed.
Protocol version The RFB Protocol version.
> To copy this information:

Click Copy to Clipboard in the Connection Info dialog. The
information is now available to be pasted into the program of your
choice.
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Connecting to a Remote KVM Console

Once you establish a connection with a Raritan device, that device's icon
in the Navigator can be expanded to display all ports enabled for remote
access.

ﬁ Raritan Devices j
—D% Bill's K232 [192.168,51,120]
— @ = billskx101 [1922,168,51.53]

— % S billskx121 [192,165,51.]

— U2 [Brown Room Domir

— g 1: Channel 2
—&= o Channel 2
— ':‘1 3 Channel 15
— ':_J, 4: Channel 4
e 'Er 5: Channel 5
—am & Channel &
— '-: 7t Channel 7
— "—: 2: Channel 2
— o= 9: Channel ©

Choose one of the following options to establish a remote KVM console
connection:

e Double-click the KVM port. This method closes any previous
connection before connecting to the new port.

¢ Right-click the port and choose Switch from the shortcut menu. This
method closes any previous connection before connecting to the
new port.

e Right-click the port and choose New Connection from the shortcut
menu. This method allows you to connect to the selected port
without closing any previous connections and creates a new
connection if the device supports multiple concurrent connections.

Once connected, Raritan KVM over IP devices display real-time video
output of the target server (this video is compressed and encrypted
according to the configuration settings specified by the administrator).
You now have complete, low-level control of the KVM console as if you
were physically located next to the server.

e To close a connection, right-click the connected device and choose
Disconnect.

e To exit completely, choose Connection > Exit.

Closing a Remote Connection

» To close the connection:
1. Select the device in the Navigator and right-click it.

2. Choose Disconnect from the shortcut menu.
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3. To exit completely, click Exit on the Connection menu

Shortcut Menu

To access the shortcut menu, use either the default keyboard
combination of Ctrl+Left Alt+M or the keyboard combination you assign.
See Changing the Shortcut Menu Keyboard Combination (on page
92) for more information.

TIP: If at some point you forget the keyboard combination used to open
the shortcut menu, press Ctrl+Left Alt at the same time. The keyboard
combination will be displayed across the bottom of the page for five
seconds.

== Raritan.

ZullfHormal Saeen

Auto Senze

Zalibrate Calor

Zonrecticn Information

Zonreckicn Properties

Yideo Settings

efrezh Screen

Synchronize Mouse

Single/Double cursar

Zend Strl+alt4Del

Zonrec Drive.,.

Zanreck CO-RIMAISO Irmags...

Zand Chrldalt+m

Zancel [Ezc)
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Shortcut Menu Key Options

Execute any of the commands on the shortcut menu by either choosing
the command in the menu or using a key combination. If you are using a
key combination to execute a command, you will press Ctrl+Left Alt+M
and then press the key on your keyboard that corresponds to the
underlined letter in the shortcut menu. For example, press Ctrl+Left
Alt+M+F to enter Full Screen mode. See the table below for information
on invoking commands from the shortcut menu using keyboard
combinations.

Note: You must use the Left Alt key on your keyboard when using the
Ctrl+Left Alt combination.

To Press Ctrl+Left Alt+M+

Toggle between Full/Normal screen F
mode*

Display connection information* I
Display or set connection properties*
Display or set video settings*
Refresh the page

Synchronize mouse

nw < 1 < T

Change to/from single/double cursor
mode

Send Ctrl+Alt+Del to the target
system

W)

Connect Drive
Connect CD-ROM/ISO Image
Send Ctrl+Alt+M to the target system

Exit a dialog or menu without altering Esc
the keyboard state

* If Full Screen mode is active, executing this command will automatically
end Full Screen mode.

Changing the Shortcut Menu Keyboard Combination

» To change the keyboard combination, do the following:
1. Choose Tools > Options to open the Options dialog.

2. From the Keyboard Shortcut Menu HotKey drop-down, select the
keyboard combination you want to use to open the shortcut menu.
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3. Click OK or Apply.

Once a new keyboard combination is assigned, the new combination will
be displayed in the shortcut menu and in the onscreen message that
displays when the combination is used.

Options

General I Advancad |

[#] show =<rall borders,

[¥] Dizplay single carsor mode Instructions,

Kayboard Type

|L|S.|"Tnternal:iona| t]

Kaybasrd Shortout Manu Hotkey

Auto-Syne mouse in tvo-cursor mode. (Mot supported for KX Generation 2)

[¥] Autarmmatic Color Calibration (For KX Generation 1 only)

=& Raritan.

Chritaltt | w
Chl 40184
Chrl=falg--0
CrlHale+p | 21,3 || Cancel ” Apply J
Ctrl+alk+o
Ctrl+Alt+R | —
Chrldale+s
Crl4alg4T "!
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Keyboard Macros

A hot key combination is a set of keystrokes that performs an action
when pressed. For example, the hot key combination Ctrl+Alt+0 might be
created to minimize all windows.

A keyboard macro is a shortcut that sends a hot key combination to a
target server. Using keyboard macros ensures that hot key combinations
intended to be used on the target server are sent to and interpreted only
by the target server, and not by the computer on which the client is
running.

Raritan strongly suggests the use of keyboard macros instead of hot key
combinations since certain hot key combinations have been found not to
work properly, depending on the platform and behavioral difference
between the application and web browser version. Specifically, using hot
keys can result in your own client PC intercepting the command and
performing the action instead of sending the command to the target
server as intended.

Note: In MPC, foreign keyboard layouts are not supported when using
keyboard macros, except for those keys listed in the Add Keyboard
Macro dialog for Japanese and Korean.

Building a Keyboard Macro

» To build a macro:

Click Keyboard > Keyboard Macros. The Keyboard Macros dialog
appears.

Click Add. The Add Keyboard Macro dialog appears.

3. Type a name for the macro in the Keyboard Macro Name field. This
name will appear in the Keyboard menu after it is created.

4. From the Hot-Key Combination field, select a keyboard combination
from the drop-down list. This allows you to execute the macro with a
predefined keystroke. Optional

5. Inthe Keys to Press drop-down list, select each key you would like to
use to emulate the keystrokes that will be used to perform the
command. Select the keys in the order by which they are to be
pressed. After each selection, select Add Key. As each key is
selected, it will appear in the Macro Sequence field and a Release
Key command will automatically be added after each selection.

6. For example, create a macro to close a window by selecting Left Ctrl
+ Esc. This will appear as the following in the Macro Sequence box:

Press Left Citrl
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Release Left Ctrl
Press Esc
Release Esc

7. Review the Macro Sequence field to be sure the macro sequence is
defined correctly.

a. Toremove a step in the sequence, select it and click Remove.

b. To change the order of steps in the sequence, click the step and
then click the up or down arrow buttons to reorder them as
needed.

8. Click OK to save the macro. Click Clear to clear all field and start
over. When you click OK, the Keyboard Macros dialog appears and
lists the new keyboard macro.

Add Keyboard Macro

Keyboard Macra Mame |C|Dse wWindow

Kevboard Macra Hotkey Mo Hot-Key -

X

Left Windows Key Release Laft Ctrl
Right Windows Key Press ESC

Menu Key Release ESC
Print ScreenfSyzRg

keys to Press Macro Sequence
All Keys "F|
Murm Lock ﬂ Prazs Left Ctrl

Pauze
ESC |

Enter ﬂ

Add Key | | FRermove | | - | | u |

| (]34 || Cancel || Clear |
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9. Click Close to close the Keyboard Macros dialog. The macro will now
appear on the Keyboard menu in the application. Select the new
macro on the menu to run it or use the keystrokes you assigned to
the macro.

Keyboard Macros rg|

Mimmize All Windows

j

Foun Macro

Add

Rermoue

Maodify

Cloze

1]

Selact a macro from the above list,

Running a Keyboard Macro

Once you have created a keyboard macro, execute it using the keyboard
macro you assigned to it or by choosing it from the Keyboard menu.

Run a Macro from the Menu Bar

When you create a macro, it appears under the Keyboard menu.
Execute the keyboard macro by clicking on it in the Keyboard menu.

Connection  USE Profile Serizl | Keyboard wideo Mouse Wirtual Media Tools Wiew Window Help

FEEEER s “ AT

Enter ©n-Screen Menu

Exit O n-Screen Menu Ezcape

Export Keyboard Macras.. .,
Import Keyboard Macras, .,

Keyboard Macras. .,

Minirmize All Wwindows Chrl+alt-0

Run a Macro Using a Keyboard Combination

If you assigned a keyboard combination to a macro when building it, you
can execute the macro by pressing its assigned keystrokes. For
example, press the keys Ctrl+Alt+0 simultaneously to minimize all
windows on a Windows target server.
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Modifying and Removing Keyboard Macros

» To modify a macro:

Choose Keyboard > Keyboard Macros. The Keyboard Macros dialog
appears.

Choose the macro from among those listed.
Click Modify. The Add/Edit Macro dialog appears.
Make your changes.

Click OK.

ok wD

v

To remove a macro:

Choose Keyboard > Keyboard Macros. The Keyboard Macros dialog
appears.

2. Choose the macro from among those listed.

3. Click Remove. The macro is deleted.

Ctrl+Alt+Del Macro

Due to its frequent use, a Ctrl+Alt+Delete macro, used to reboot the
target computer, has been preprogrammed. Clicking on the

P
Ctrl+Alt+Delete button HEZE in the toolbar sends this key sequence to
the server or to the KVM switch to which you are currently connected.

In contrast, if you were to physically press the Ctrl+Alt+Del keys, the
command would first be intercepted by your own PC due to the structure
of the Windows operating system, instead of sending the key sequence
to the target server as intended.

Common Hot Key Exceptions for MPC

The following common hot key combinations are not sent to the target
system:

Hot Key Description
Combination

Ctrl+Alt+Delete  Reboots the computer. The sequence is sent to the
local system and the Windows Security (Task
Manager, Shutdown, and so on) dialog is displayed.

Ctrl+Left Alt+M  Brings up the shortcut menu (on page 91).
Print Scrn Treated locally and copies the page to the clipboard.

Following are limitations to specific keyboards and hot key combinations:

97



Chapter 3: Multi-Platform Client and Raritan Remote Client

Hot Key
Combination

Alt Gr

Alt+SysRqg+[key]

Description

Because of a limitation in the Java Runtime
Environment (JRE), Fedora, Linux, and Solaris
clients receive an invalid response from Alt Gr on
United Kingdom and US International language
keyboards.

Fedora, Linux, and Solaris do not pick up events
for the Alt Gr key combination for Java 1.5. Java
1.6 appears to improve on this, although the
keyPressed and keyReleased events for Alt Gr still
identify it as an “unknown key code”.

Further, a key pressed in combination with Alt Gr
(such as on the UK keyboard Alt Gr-4, which is the
Euro symbol), will only generate a keyTyped
followed by a keyReleased event for that value
without a keyPressed event. Java 1.6 improves
upon this by filling in the keyPressed event as well.

Since the SysRq keyboard stroke is used by some
operating systems as a print shortcut, the Alt +
SysRq + [key] combination is supported only as a
macro when using with RRC and MPC to a Linux
target.

Common Hot Key Combinations for RRC

The following common hot key combinations are not sent to the target

system:

Hot Key
Combination

Ctrl+Alt+Delete

Ctrl+Num Lock

Ctrl+Caps Lock

Ctrl+Scroll Lock

98

Description

Reboots the computer. The sequence is sent to the
local system and the Windows Security (Task
Manager, Shutdown, and so on) dialog is displayed.

This toggles the state of the Num Lock light if the
Num Lock state on the local system is not the same
as the target system.

This toggles the state of the Caps Lock light if the
Caps Lock state of the local system is not the same
as the target system.

This toggles the state of the Scroll Lock light if the
Scroll Lock state of the local system is not the same
as the target system.
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Hot Key Description
Combination

Ctrl+Left Alt+M  Brings up the shortcut menu (on page 91).
Print Scrn Treated locally and copies the page to the clipboard.

Following are limitations to specific keyboards and hot key combinations:

Hot Key Description
Combination

Alt+SysRqg+[key]  Since the SysRq keyboard stroke is used by
some operating systems as a print shortcut, the
Alt + SysRq + [key] combination is supported
only as a macro when using with RRC and
MPC to a Linux target.

Windows Key in MPC

When running MPC on a Windows JRE 1.5.0_x platform, if you press the
Windows key & to display the Start menu, the Start menu will only
appear on the client machine. The key is not sent to the target device.

When running MPC on a Windows JRE 1.5.0_x platform, if you press the
Windows key, the Start menu appears on both the client and the target
devices. Use your mouse to manually close the Start menu if you do not
want to use.

Note that if you do not close the target device's Start menu properly, any
key that you touch on your keyboard (that has a Windows key
combination function) will send that command to the target device. For
example, if you press E, the target device will open a new Explorer
window. If you press D, all target windows will be minimized so you can
view the desktop. To close the Start menu on the target device, click the
Start button or click off of the Start menu.

Keyboard Type

Specifying a Keyboard Type in MPC
MPC will not autodetect the type of keyboard you use, so you must

specify your keyboard type to ensure accurate keyboard mapping.

» To specify a keyboard type:
1. Choose Tools > Options. The Options dialog will appear.

2. Click the Keyboard Type drop-down and select your keyboard type
from the list.
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US/International
French (France)
German (Germany)
Japanese

United Kingdom
Korean (Korea)
Belgian (Belgium)
Norwegian (Norway)
Danish (Denmark)
Swedish (Sweden)
German (Switzerland)
Hungarian (Hungary)
Spanish (Spain)
Italian (Italy)

Slovenian
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3. Click OK.

Options E'

General | Advanced |

Show scrall barders,
Auto-Sunc rnouse in two-cursar rmode, (Mot supported for KX Generation 2]
Display single cursor mode instruckions,

Autornatic Color Calibration [For KX Generation 1 only)

Kevboard Type

s/ International -

U5/ International =
French [(France]
KdGerman [Garmany] btk ay
Japanese

United Kingdorn

Korean [Kaoreal —
Belgian [Belgiur]
Maorwegian [(Morway) j

| (]34 || Cancel || Apply |

Keyboard Limitations

Japanese Kanji Keyboards

For Kanji keyboards, when using DCIM-USBs and MPC, the remote
client cannot enter EISU mode by pressing the Caps Lock key (key#30).
Local port access is not affected. You can access the DCIM-USBs using
RRC or using the keyboard macro Shift + Caps Lock in MPC.

Slovenian Keyboards

The < key does not work on Slovenian keyboards due to a JRE
limitation.

Language Configuration on Linux

Because the Sun JRE on Linux has problems generating the correct Key
Events for foreign-language keyboards configured using System
Preferences, Raritan recommends that you configure foreign keyboards
using the methods described in the following table.

101
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Language Configuration method

us Intl Default

French Keyboard Indicator

German System Settings (Control Center)
Japanese System Settings (Control Center)
UK System Settings (Control Center)
Korean System Settings (Control Center)
Belgian Keyboard Indicator

Norwegian Keyboard Indicator

Danish Keyboard Indicator

Swedish Keyboard Indicator

Hungarian System Settings (Control Center)
Spanish System Settings (Control Center)
Italian System Settings (Control Center)
Slovenian System Settings (Control Center)

Note: The Keyboard Indicator should be used on Linux systems using
Gnome as a desktop environment.

Video Properties

Refresh Screen

The Refresh Screen command forces a refresh of the video screen.
Video settings can be refreshed automatically in several ways:

e The Refresh Screen command forces a refresh of the video screen.

e The Auto-sense Video Settings command automatically detects the
target server's video settings.

e The Calibrate Color command calibrates the video to enhance the
colors being displayed.

In addition, you can manually adjust the settings using the Video Settings
command.

» To refresh the video settings, do one of the following:
e Choose Video > Refresh Screen or click the Refresh Screen button

ﬁ in the toolbar.
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Auto-Sense Video Settings

The Auto-sense Video Settings command forces a re-sensing of the
video settings (resolution, refresh rate) and redraws the video screen.

» To automatically detect the video settings, do the following:
e Choose Video > Auto-sense Video Settings or click the Auto-Sense

-——
o T

Video Settings button #k: 1 in the toolbar. A message stating that the
auto adjustment is in progress appears.

Calibrate Color

Use the Calibrate Color command to optimize the color levels (hue,
brightness, saturation) of the transmitted video images. The color
settings are on a target server-basis.

Note: The Calibrate Color command applies to the current connection
only.

P To calibrate the color, do the following:
e Choose Video > Calibrate Color or click the Calibrate Color button

IEI in the toolbar. The target device screen updates its color
calibration.

Video Settings

Use the Video Settings command to manually adjust the video settings.

> To change the video settings:
Choose Video > Video Settings or click the Video Settings button

in the toolbar to open the Video Settings dialog.

2. Adjust the following settings as required. As you adjust the settings
the effects are immediately visible:

a. Noise Filter

The device can filter out the electrical interference of video
output from graphics cards. This feature optimizes picture quality
and reduces bandwidth. Higher settings transmit variant pixels
only if a large color variation exists in comparison to the
neighboring pixels. However, setting the threshold too high can
result in the unintentional filtering of desired screen changes.
Lower settings transmit most pixel changes. Setting this
threshold too low can result in higher bandwidth use.
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b. Brightness: Use this setting to adjust the brightness of the target
server display.

c. Brightness Red - Controls the brightness of the target server
display for the red signal.

d. Brightness Green - Controls the brightness of the green signal.

e. Brightness Blue - Controls the brightness of the blue signal.
f. Contrast Red - Controls the red signal contrast.

g. Contrast Green - Controls the green signal.

h. Contrast Blue - Controls the blue signal.

If the video image looks extremely blurry or unfocused, the
settings for clock and phase can be adjusted until a better image
appears on the active target server.

Warning: Exercise caution when changing the Clock and Phase
settings. Doing so may result in lost or distorted video and you may
not be able to return to the previous state. Contact Raritan Technical
Support before making any changes.

i. Clock - Controls how quickly video pixels are displayed across
the video screen. Changes made to clock settings cause the
video image to stretch or shrink horizontally. Odd number
settings are recommended. Under most circumstances this
setting should not be changed because the autodetect is usually
quite accurate.

j- Phase - Phase values range from 0 to 31 and will wrap around.
Stop at the phase value that produces the best video image for
the active target server.

k. Horizontal Offset - Controls the horizontal positioning of the
target server display on your monitor.

I.  Vertical Offset - Controls the vertical positioning of the target
server display on your monitor.

3. Select Auto Color Calibration to enable this feature.
4. Select the video sensing mode:
= Best possible video mode

The device will perform the full Auto Sense process when
switching targets or target resolutions. Selecting this option
calibrates the video for the best image quality.

= Quick sense video mode

With this option, the device will use a quick video Auto Sense in
order to show the target's video sooner. This option is especially

useful for entering a target server's BIOS configuration right after
a reboot.
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5. Click OK to apply the settings and close the dialog. Click Apply to
apply the settings without closing the dialog.

Note: Some Sun background screens, such as screens with very dark
borders, may not center precisely on certain Sun servers. Use a different
background or place a lighter colored icon in the upper left corner of the
screen.

Video Setiings E|
Moise Filter < | x z
Brightness Red < I bd 45
Brightness Green £ | > B
Brightness Blue < I 3 46
ContrastRed ¢ ! > 192
Contrast Green Al | * 196
ContrastBlue € | b 184
Clock € ¥ 056
Fhase p | ¥ 19
Haorizantal Offsct ) [ 214
Werical Offzet < | * 232
v iAuto Color Calibration:
& Bestpossible video mode
" Quick sense video mode
ok | cance | il |

Using Screenshot from Target

You are able to take a screenshot of a target server using the
Screenshot from Target server command. You save this screenshot to a
file location of your choosing and can save it as either a bitmap, JPEG,
or PNG file.

> To take a screenshot of the target server:
Select Video > Screenshot from Target or click the Screenshot from

2
Target button [4'5" on the toolbar.

2. Inthe Save dialog, choose the location to save the file, name the file,
and select a file format from the 'Files of type' drop-down.
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3. Click Save to save the screenshot.

Saue jnt ([ My Downloads H |Eﬂ| |ﬁ| ||j| E:E: E:

[ Miscellaneous

|j| HTMLbackground.jpg

File name: Server Screenshntl

Files of type: [JPES image files -

Save || Cancel |
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Mouse Options

Single Cursor Mode/Dual Cursor Mode

When remotely viewing a target server that uses a mouse, you will see
two mouse cursors on the remote desktop. When your mouse pointer
lies within the remote desktop area, mouse movements and clicks are
directly transmitted to the connected target server. The pointer,
generated by the operating system, slightly leads the target server's
mouse pointer during movement. This is a result of digital delay.

On fast LAN connections, you may want to disable the mouse pointer
and view only the target server's pointer. To toggle between these two
modes, choose Single/Double Cursor on the shortcut menu.

Alternatively, click the Single Mouse Pointer button b in the toolbar or
choose Mouse > Single Cursor Mode.

single Cursor Mode

Y'ou are about bo enter Single Cursor mode, “While you are if thiz mode,
thiz sofbware will have exclusive contral over the mouse and keyboard.

To et Single Cursor mode vou must press;

Ctrl + Alt + b, then S

W Show thiz dislog each time vou start Single Cursor mode.

k. | Cancel

When in Dual Cursor mode, press Ctrl+Left Alt+M and execute the
Synchronize Mouse shortcut to force realignment of the mouse cursors.
If the mouse cursors still remain out of sync, click the Auto-Sense Video

Settings button on the toolbar.

Note: When in Dual Cursor mode, if the dual mouse cursors are
synchronized but left idle for five minutes or longer, the target mouse
pointer will automatically align itself with the upper left corner of the
target window. Execute the Synchronize Mouse command to ensure
local and target mouse pointer alignment.

Single Mouse Cursor mode for Apple Mac target servers is supported for
MPC. Select Single Mouse Cursor on the Mouse menu in MPC to enter
this mode. While in this mode, the cursor will remain in the video
window for the Mac Server. To exit, open the shortcut menu and press
S on the keyboard.
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Mouse Synchronization Options

In addition to synchronizing mouse cursors or toggling between single
and dual cursor mode, the Mouse menu provides three options for
synching cursors when in dual cursor mode:

Menu option  Description

Absolute When connected to selected Dominion devices and
targets with USB ports, the application will use
absolute coordinates to keep the cursors in sync.
See Absolute Mouse Mode for more information.

Intelligent Under certain conditions, the application can detect
the target mouse settings and synchronize the
mouse cursors accordingly, accelerating the mouse
on the target device. See Intelligent Mouse Mode
(on page 20) for more details.

Standard This is the standard mouse synchronization
algorithm. See Standard Mouse Mode (on page 19)
for more information.

Note: The Intelligent and Standard Mouse modes are available to all
targets. Absolute Mouse mode are only available to Mac and Windows
USB targets.

Automatic Mouse Synchronization

For Generation 1, devices When in Dual Cursor mode, the system will
automatically align the mouse cursors when the cursor is inactive for 15
seconds. Enable this feature by clicking the Synchronize Mouse button

in the toolbar or selecting Tools > Options and selecting the
"Auto-Sync mouse in two-cursor mode" checkbox.

Automatic Mouse Synchronization is available for Generation 2 devices
when:

e A new connection is established
e Auto-sense is enabled
e Color calibration is enabled

Enable this feature in Generation 2 devices by clicking the Synchronize

Mouse button in the toolbar or selecting Mouse > Synchronize
Mouse.
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Absolute Mouse Mode

In this mode, absolute coordinates are used to keep the client and target
cursors in sync, even when the target mouse is set to a different
acceleration or speed. This mode is supported on servers with USB
ports.

» To enter absolute mouse mode:
e Choose Mouse > Absolute.

Note: The absolute mouse setting requires a USB target system and is
the recommended mouse setting for KX 11-101.

Note: Absolute Mouse Synchronization is available for use with the
virtual media-enabled USB CIM (D2CIM-VUSB and D2CIM-DVUSB)
only.
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Intelligent Mouse Mode

In Intelligent Mouse mode, the device can detect the target mouse
settings and synchronize the mouse cursors accordingly, allowing mouse
acceleration on the target. In this mode, the mouse cursor does a
“dance” in the top left corner of the screen and calculates the
acceleration. For this mode to work properly, certain conditions must be
met.

» To enter intelligent mouse mode:
e Choose Mouse > Intelligent.

Intelligent Mouse Synchronization Conditions

The Intelligent Mouse Synchronization command, available on the
Mouse menu, automatically synchronizes mouse cursors during
moments of inactivity. For this to work properly, however, the following
conditions must be met:

e The active desktop should be disabled on the target.
¢ No windows should appear in the top left corner of the target page.

e There should not be an animated background in the top left corner of
the target page.

e The target mouse cursor shape should be normal and not animated.

e The target mouse speeds should not be set to very slow or very high
values.

e Advanced mouse properties such as “Enhanced pointer precision” or
“Snap mouse to default button in dialogs” should be disabled.

e Choose “Best Possible Video Mode” in the Video Settings window.

e The edges of the target video should be clearly visible (that is, a
black border should be visible between the target desktop and the
remote KVM console window when you scroll to an edge of the
target video image).

e When using the intelligent mouse synchronization function, having a
file icon or folder icon located in the upper left corner of your desktop
may cause the function not to work properly. To be sure to avoid any
problems with this function, Raritan recommends you do not have file
icons or folder icons in the upper left corner of your desktop.

After autosensing the target video, manually initiate mouse
synchronization by clicking the Synchronize Mouse button on the toolbar.
This also applies when the resolution of the target changes if the mouse
cursors start to desync from each other.

If intelligent mouse synchronization fails, this mode will revert to standard
mouse synchronization behavior.
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Please note that mouse configurations will vary on different target
operating systems. Consult your OS guidelines for further details. Also
note that intelligent mouse synchronization does not work with UNIX
targets.

Standard Mouse Mode

Standard Mouse mode uses a standard mouse synchronization
algorithm using relative mouse positions. Standard Mouse mode requires
that mouse acceleration is disabled and other mouse parameters are set
correctly in order for the client and server mouse to stay synchronized.
Standard Mouse mode is the default.

» To enter standard mouse mode:
e Choose Mouse > Standard.

Connection and Video Properties

Dynamic video compression algorithms maintain KVM console usability
under varying bandwidth constraints. The device optimizes KVM output
not only for LAN use but also for WAN and dial-up use. These devices
can also control color depth and limit video output, offering an optimal
balance between video quality and system responsiveness for any
bandwidth constraint.

The parameters discussed in this section can be optimized in the
Connection Properties dialog and Video Settings dialog. The properties
that you apply to a connection are retained between connections, they
do not reset to their defaults.
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MPC Connection Properties - Generation 1 Devices

» To adjust connection properties:

1. Choose Connection > Properties or click the Connection Properties

button E‘ in the toolbar. Update the settings in the Compression
tab.

Properlies Dialog

Compression |

Connecion Spead;: |¢°~,_;,|‘§.a Catack

Color Depth: |Auto Select Color

[« [«

|:| Progressive Update

[ ] 1nternet Flaw Contral

S CH :
RBECAE L E T High

Frarmes per zecond

@H'Fruq I:::I1I'I'F|-|~: I:::I 20N fns

| [e] 4 || Cancel || Apple |

2. Set the Connection Speed.

Use this setting to manually adjust the connection speed to
accommodate bandwidth constraints. Devices can automatically
detect available bandwidth and not limit bandwidth use. However,
you can also adjust this usage according to your needs. Depending
on the Raritan device in use, different options may be available:

= Auto Detect

= 1G Ethernet

= 100mb Ethernet

= 10mb Ethernet

= 1.5mb (Max DSL/T1)

= 1mb (Fast DSL/T1)

= 512 kb (Medium DSL/T1)
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= 384 kb (Slow DSL/T1)
= 256 kb (Cable)

= 128 kb (Dual ISDN)

= 56 kb (ISP Modem)

= 33 kb (Fast Modem)

= 24 kb (Slow Modem)
Set the Color Depth.

Devices can dynamically adapt the color depth transmitted to remote
users in order to maximize usability in all bandwidths. Select from
among the options in the drop-down list. Depending on the Raritan
device in use, different options may be available:

= 15-bit RGB Color
= 8-bit RGB Color

= 4-hit Color
= 4-bit Gray
= 3-bit Gray
= 2-bit Gray

= Black and White

Important: For most administrative tasks (server monitoring,
reconfiguring, and so forth), administrators do not require the full
24-bit or 32-bit color spectrum made available by most video
graphics cards. Attempting to transmit such high color depths wastes
network bandwidth.

Selecting the Internet Flow Control checkbox ensures that packets
transmitted by the device are received and reconstructed by the
client application in the correct order. This is useful when using a
device over an unpredictable public WAN (particularly in international
scenarios).

Use the slider to select the desired level of video Smoothing (15-bit
mode only). The level determines how aggressively to blend page
regions with small color variation into a single, smooth color.
Smoothing improves the appearance of the target video by reducing
the video noise that is displayed.

Select "Frames per second". This setting instructs MPC on how often
to redraw the video display of the target. This only affects the client
display behavior and has no bearing on the data rate of the video
being sent to the client. Setting this option higher makes the video
appear smoother but also requires more processing power.

Click OK to create the connection profile.
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MPC Connection Properties - Generation 2 Devices

» To adjust connection properties:
1. Choose Connection > Properties or click the Connection Properties

button E‘ in the toolbar. Update the settings in the Compression
tab.

2. Set the Connection Speed.

Use this setting to manually adjust the connection speed to
accommodate bandwidth constraints. Devices can automatically
detect available bandwidth and not limit bandwidth use. However,
you can also adjust this usage according to your needs. Depending
on the Raritan device in use, different options may be available:

= Auto Detect

= 1G Ethernet

= 100mb Ethernet

= 10mb Ethernet

*  1.5mb (Max DSL/T1)
= 1mb (Fast DSL/T1)

» 512 kb (Medium DSL/T1)
» 384 kb (Slow DSL/T1)
= 256 kb (Cable)

= 128 kb (Dual ISDN)

= 56 kb (ISP Modem)

= 33 kb (Fast Modem)

= 24 kb (Slow Modem)

Note: KX 1I-101 does not support 1G Ethernet.

3. Set the Color Depth.

Devices can dynamically adapt the color depth transmitted to remote
users in order to maximize usability in all bandwidths. Select from
among the options in the drop-down list. Depending on the Raritan
device in use, different options may be available:

= 15-bit RGB Color
= 8-bit RGB Color

= 4-bit Color
= 4-bit Gray
= 3-bit Gray
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= 2-bit Gray
= Black and White

Important: For most administrative tasks (server monitoring,
reconfiguring, and so forth), administrators do not require the full
24-bit or 32-bit color spectrum made available by most video
graphics cards. Attempting to transmit such high color depths wastes
network bandwidth.

Use the slider to select the desired level of video Smoothing (15-bit
mode only). The level determines how aggressively to blend page
regions with small color variation into a single, smooth color.
Smoothing improves the appearance of the target video by reducing
the video noise that is displayed.

5. Click OK to create the connection profile.

Properties Dialog E'
Cormpression |
Connection Speed: |Auto Detect |
Color Depth: [15-bit RGE Color -
Emoothing! I\_/} " Low
| Caf | | Cancel | | Apply |
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RRC Connection Properties

» To adjust connection properties:

1. Choose Connection > Properties or click the Connection Properties

button E‘ in the toolbar. Update the settings in the Compression
tab.

Modify Connection

ompreszion

Connection Speed:

Color Depth:

I Irterret Flow Cantral

S moothing [t -—J' GED

Ok l Cancel J b anly

2. Set the Connection Speed.

Use this setting to manually adjust the connection speed to
accommodate bandwidth constraints. Devices can automatically
detect available bandwidth and not limit bandwidth use. However,
you can also adjust this usage according to your needs. Depending
on the Raritan device in use, different options may be available:

= Auto Detect

= 1G Ethernet

= 100mb Ethernet

= 10mb Ethernet

*  1.5mb (Max DSL/T1)

= 1mb (Fast DSL/T1)

» 512 kb (Medium DSL/T1)
= 384 kb (Slow DSL/T1)
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= 256 kb (Cable)

= 128 kb (Dual ISDN)
= 56 kb (ISP Modem)
= 33 kb (Fast Modem)
= 24 kb (Slow Modem)
Set the Color Depth.

Devices can dynamically adapt the color depth transmitted to remote
users in order to maximize usability in all bandwidths. Select from
among the options in the drop-down list. Depending on the Raritan
device in use, different options may be available:

= 15-bit RGB Color
= 8-bit RGB Color

= 4-hit Color
= 4-bit Gray
= 3-bit Gray
= 2-bit Gray

= Black and White

Important: For most administrative tasks (server monitoring,
reconfiguring, and so forth), administrators do not require the full
24-bit or 32-bit color spectrum made available by most video
graphics cards. Attempting to transmit such high color depths wastes
network bandwidth.

Select Progressive Update to increase the usability in constrained
bandwidth environments. When Progressive Update is enabled, the
device initially sends an image of the remote desktop at lower color
depths. Higher color depth images are provided as the bandwidth
allows.

Note: When Color Depth is set to Auto Select Color (default),
Progressive Update is automatic. The device will enable/disable
Progressive Update as required, disabling it for fast connections and
enabling it for slow connections.

Selecting the Internet Flow Control checkbox ensures that packets
transmitted by the device are received and reconstructed by the
client application in the correct order. This is useful when using a
device over an unpredictable public WAN (particularly in international
scenarios).
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6.

7.

Use the slider to select the desired level of video Smoothing (15-bit
mode only). The level determines how aggressively to blend page
regions with small color variation into a single, smooth color.
Smoothing improves the appearance of the target video by reducing
the video noise that is displayed.

Click OK to create the connection profile.

Video Settings

Video Settings - Generation 1 Devices

Following are instructions on configuring video settings for Generation 1
devices. These settings can be refreshed using the Color Calibration
command by manually forcing a device to autodetect the video settings
(on the Video menu, click Auto-sense Video Settings) or by changing the
settings in this page. After you change a value, click Apply to test the
setting. See Color Calibration (on page 123).

>

1.

To configure Generation 1 devices:
Choose Video > Video Settings or click the Video Settings button

% in the toolbar to open the Settings dialog.
Adjust the following settings as required:
a. Noise Filter

Devices can filter out the electrical interference of video output
from graphics cards. This feature optimizes picture quality and
reduces bandwidth. Higher settings transmit variant pixels only if
a large color variation exists in comparison to the neighboring
pixels. However, setting the threshold too high can result in the
unintentional filtering of desired page changes. Lower settings
transmit most pixel changes. Setting this threshold too low can
result in higher bandwidth use.

Note: The default Noise Filter is 4. Raritan recommends that you
lower this value to 0 (zero). Although higher settings will stop the
needless transmission of false color variations, true and intentional
small changes to a video image may not be transmitted.

b. PLL Settings

If the video image looks extremely blurry or unfocused, the PLL
settings for clock and phase can be adjusted until a better image
appears on the active target server.

Warning: Exercise caution when changing the clock and phase
settings since doing so may result in lost or distorted video and you
may not be able to return to the previous state. Contact Raritan
Technical Support before making any changes.
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Clock - Controls how quickly video pixels are displayed across
the video page. Changes made to clock settings cause the video
image to stretch or shrink horizontally. Odd number settings are
recommended. Under most circumstances this setting should not
be changed because the autodetect is usually quite accurate.

Phase - Phase values range from 0 to 31 and will wrap around.
Stop at the phase value that produces the best video image for
the active target server.

Color Settings - Gain control can be thought of as contrast
adjustment. Offset control can be thought of as brightness
adjustment.

Select the Link Color Controls checkbox to make all slide
adjusters move in unison when any one option is moved.

Red Gain - Controls the amplification of the red signal.
Red Offset - Controls the bias of the red signal.

Green Gain - Controls the amplification of the green signal.
Green Offset - Controls the bias of the green signal.

Blue Gain - Controls the amplification of the blue signal.

Blue Offset - Controls the bias of the blue signal.

Select the video sensing mode:

Best possible video mode - Devices will perform the full Auto
Sense process when switching targets or target resolutions.
Selecting this option calibrates the video for the best image
quality.

Quick sense video mode - Selecting this option will cause the
device to use a quick video Auto Sense in order to show the
target's video sooner. This option is especially useful for entering
a target server's BIOS configuration right after a reboot.

Click OK to apply the settings and close the dialog. Click Apply to
apply the settings without closing the dialog.
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Note: Some Sun background screens, such as screens with very dark
borders, may not center precisely on certain Sun servers. Use a different
background or place a lighter colored icon in the upper left corner of the

page.
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Video Settings - Generation 2 Devices

» To configure Generation 1 devices:
1. Choose Video > Video Settings or click the Video Settings button

@ in the toolbar to open the Settings dialog.
2. Adjust the following settings as required:
a. Noise Filter

Devices can filter out the electrical interference of video output
from graphics cards. This feature optimizes picture quality and
reduces bandwidth. Higher settings transmit variant pixels only if
a large color variation exists in comparison to the neighboring
pixels. However, setting the threshold too high can result in the
unintentional filtering of desired page changes. Lower settings
transmit most pixel changes. Setting this threshold too low can
result in higher bandwidth use.
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Note: The default Noise Filter is 4. Raritan recommends that you
lower this value to 0 (zero). Although higher settings will stop the
needless transmission of false color variations, true and intentional
small changes to a video image may not be transmitted.

b. PLL Settings

If the video image looks extremely blurry or unfocused, the PLL
settings for clock and phase can be adjusted until a better image
appears on the active target server.

Warning: Exercise caution when changing the clock and phase
settings since doing so may result in lost or distorted video and you
may not be able to return to the previous state. Contact Raritan
Technical Support before making any changes.

= Clock - Controls how quickly video pixels are displayed across
the video page. Changes made to clock settings cause the video
image to stretch or shrink horizontally. Odd number settings are
recommended. Under most circumstances this setting should not
be changed because the autodetect is usually quite accurate.

= Phase - Phase values range from 0 to 31 and will wrap around.
Stop at the phase value that produces the best video image for
the active target server.

a. Color Settings

These settings control the brightness, contrast, and positioning of
the target server display. Select the Link Color Controls checkbox
to make all slide adjusters move in unison when any one option

is moved.

= Brightness Red - Controls the brightness of the red signal;
range is 0 - 127.

= Brightness Green - Controls the brightness of the green signal;
range is 0 - 127.

= Brightness Blue - Controls the brightness of the blue signal;
range is 0 - 127.

= Contrast Red - Controls the red signal contrast; range is O -
255.

= Contrast Green - Controls the green signal contrast; range is O -
255.

= Contrast Blue - Controls the blue signal contrast; range is O -
255,

= Horizontal Offset - Controls the horizontal positioning of the
target server display on your monitor; range is 0 - 512.

= Vertical Offset - Controls the vertical positioning of the target
server display on your monitor; range is 0 - 128.
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3. To preview the change prior to making the selection, check the
Preview checkbox.

4. Check the Automatic Color Calibration checkbox to enable this
feature.

5. Select the video sensing mode:

= Best possible video mode - Devices will perform the full Auto
Sense process when switching targets or target resolutions.
Selecting this option calibrates the video for the best image
quality.

= Quick sense video mode - Selecting this option will cause the
device to use a quick video Auto Sense in order to show the
target's video sooner. This option is especially useful for entering
a target server's BIOS configuration right after a reboot.

6. Click OK to apply the settings and close the dialog. Click Apply to
apply the settings without closing the dialog.
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Port Access Page Sort

» To change the display sort order:

e Click the column heading by which you want to sort. The list of KVM
target servers is sorted by that column.

Color Calibration

Use the Color Calibration command if the color levels (hue, brightness,
and saturation) of the transmitted video images do not seem accurate.
The device color settings remain the same when switching from one
target KVM server to another, so you can perform color calibration once
to affect all connected target servers.

1. Open aremote KVM connection to any server running a graphical
user interface.

2. Ensure that a solid white color covers approximately 15% or more of
the target server's desktop.

TIP: Open Microsoft Notepad and maximize the window.
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3. On the Video menu, choose Calibrate Color or click the Color

Calibration button IEI on the toolbar. The target device page will
update its calibration.

Tip: You can also specify automatic color calibration using Tools >
Options. See General Options in MPC (on page 125)for more
information.
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Help Options

This menu command provides version information about the Virtual KVM
Client, in case you require assistance from Raritan Technical Support.

> To obtain version information:
e Choose Help > About Raritan Multi-Platform Client.

Use the Copy to Clipboard button to copy the information contained in
the dialog to a clipboard file so it can be accessed later (if needed).

About Raritan Multi-Platform Client

== Raritan.

Raritan Multi-Platfarrn Client

Version: £,0,0,1,13_ 2003090222100
WM Wersion: 1.3.0_10
M Vendor: Sun Microsysterns Inc,
Operating Systern: Windaows XP

Cperating Systern Wersion: 5.1
Systern Architecture: =56

Copyright () 2004 - 2008 Raritan Cormputer, Inc All rights rezerved.

| (o] 4 || Copy to Clipboard

Administrative Functions

Although your device provides a remote interface to administrative
functions through the device manager, the client provides an interface to
frequently-used administrative functions directly from its own interface.
When logged into a device as an administrator, you can perform the
administrative tasks discussed here.

Note: Most of the commands discussed here are available in both the
Tools menu and in the shortcut menu that appears when you right-click
the device in the Navigator panel.
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Note to MPC Users

MPC users must belong to the Administrator group in order to receive
administrative permissions. MPC uses one permission: either
Administrator or Normal User. It is only when the user belongs to the
Administrator group that they have access to backup, restore, and restart
functions. This is true regardless of any device user group settings that
may be applied to the user.

General Options

General Options in MPC

The Options available in the Tools menu provide options that allow you
to customize scroll borders, mouse mode settings, Single Cursor mode,
auto color calibration, hot key configuration, keyboard type, broadcast
port, and logging.

> To configure the general options in MPC:

1. Choose Tools > Options. The Options dialog appears and displays
the General tab by default.

Options E|
General | Advanced

Show scroll borders,

Auto-Syne rrouse in two-cupzor rmode. (Mot supparted far KX Generation 2]
Display single cursar mode instructions,

E‘ fubamatic Colar Calibrati=n (For KX Generation 1 only)

Keyboard Type
Us/Intern ational b4

Keyboard Shorcut Menu Hotkey

CtrltAlt+n | e

| (=14 || Cancel || Appliy |

2. Select the "Show scroll borders" checkbox to view the thin scroll
borders designating the autoscroll area.

3. Select the "Auto-Sync mouse in two-cursor mode" checkbox to
enable automatic mouse synchronization.
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4. If you select the "Display single cursor mode instructions" checkbox,
the Single Cursor Mode dialog will appear each time Single Cursor is
enabled in the application. See Mouse Options (on page 107) for
more information.

5. Select the Automatic Color Calibration checkbox to enable automatic
color calibration. This option is available for KX generation 1 (G1)
only.

6. Select the Keyboard Type from the drop-down list (depending on the
Raritan device in use, different options may be available):

= US/International

= French (France)

=  German (Germany)
= Japanese

= United Kingdom

= Korean (Korea)

= Belgian (Belgium)

= Norwegian (Norway)
= Danish (Denmark)

= Swedish (Sweden)

=  German (Switzerland)
= Hungarian (Hungary)
= Spanish (Spain)

= |talian (Italy)

= Slovenian

7. From the Keyboard Shortcut Menu HotKey drop-down, select the key
combination you would like to use to invoke the Shortcut Menu (on
page 91).
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General Advanced |
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, open the Advanced tab.

S

i

Raritan.

KM Switch OSUI Hot Key
@ Scrall Lack + Scrall Lack
() Mum Lock + Hum Lock

) Gaps Lotk + Caps Lock

Broadcast Port

Port |S000

IPwE Metworking

I:l Enable IPvE Metworking

Logging

El Enable Lagging

| [=1.3 || Cancel || Apply |

10.

11.

12.

13.

From the KVM Switch OSUI Hot Key section, select the hot key to
use when switching between target server displays.

For the Broadcast Port, type the broadcast port number in the Port
field if you want to use a port other then 5000.

Select the Enable IPv6 Networking checkbox for IPv6 to enable IPv4
and IPv6 dual-stack operation.

Note: KSX Il and KX 11-101 devices are not IPv6 enabled, so this
section will not apply to those devices.

Select the Enable Logging checkbox only if directed to by Technical
Support. This option creates a log file in your home directory.

Click OK when finished. Click Apply any time while making
selections to apply it.
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General Options in RRC

The Options available in the Tools menu provide options that allow you
to customize scroll borders, mouse mode settings, single cursor mode,
auto color calibration, hot key configuration, keyboard type, broadcast

port, and logging.

» To configure the general options in RRC:

1. In RRC, choose Tools > Options to open the Options dialog.

Options

General ]

- Logging

[ Skow scroll barders,

[ Emable Logging

W ALLU-S I UL i Ll L e,

[# Ditplay single cursor mode insctions.,

v Avto-Color Celibratian,
KM Swib=k NS HAE K ey -

@ Semlll ack + Seealll Ak

 Mum Lock, + Mumn Lack
T Caps Lock + Caps Lock

K.euboard Shorlcut b enu Hotlkey

Hotkey |Chl + At + b =

~ Broadcas: Port -

Part {2000

X

o]

Cancel

2. Select the "Show scroll borders" checkbox to view the thin scroll
borders that show the Auto-Scroll area.

3. Select the "Auto-Sync mouse in two cursor mode" checkbox to
enable Automatic Mouse Synchronization.

e
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If you select the "Display single cursor mode instructions" checkbox
the Single Cursor Mode dialog will open each time Single Cursor is
enabled in the application (see Mouse Options (on page 107) for
more information).

Select Auto-Color Calibration to enable it.

In the KVM Switch OSUI Hot Key panel, select the radio button next
to the hot key combination you would like to use.

In the Keyboard Type panel, click on the drop-down arrow and click
on your keyboard choice.

In the Broadcast Port panel, type the broadcast port number in the
Port field.

Click OK when finished. Click Apply any time during your selection to
apply an option you have chosen.

Upgrading Device Firmware

>

To update a device's firmware:

Connect to the device by highlighting the device's icon in the
Navigator.

Click Tools > Update > Update Device to perform firmware
upgrades.

You will be prompted to locate a Raritan firmware distribution file
(*.RFP format), which can be found on the Raritan website
(www.raritan.com) on the Firmware Upgrades page.

Ensure that you read all instructions included in Firmware Upgrade
Guide carefully before upgrading a device.

Note: Copy the firmware update file on the Raritan website to a local
machine before uploading. Do not load the file from a network drive.

Clearing ActiveX Controls

After upgrading the to a newer firmware version, if you still see the
previous RRC version, please use the steps below to clear the ActiveX

cache.

> Toremove TeleControl class files:

1. InInternet Explorer 7, click Tools > Manage Addons > Enable or
Disable Addons.

2. Select "Download ActiveX control 32 bit" from the Show drop down.
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Select TeleControl class and then click Delete.
Close any open sessions of IE7.

Open a new IE7 session and go to Raritan's website to download the
newest version of RRC.

Changing a Password

» To update your password
Connect to a target by selecting it in the Navigator.

2. Highlight the target's icon in the Navigator and then choose Tools >
Update > User Password. The Change Password dialog appears.

Change Password u x|

~Info

Old Password |**********

Mew Paszword |

Confirm Mew Password |

| [al04 | | Cancel |

Type your current password in the Old Password field.
Type the new password in the New Password field.
Retype the password in the Confirm New Password field.
When finished, click OK.

2 e

Restarting a Device

> To restart a device:
1. Select the device in the Navigator.

2. On the Tools menu, choose Restart Device.

Backup and Restore Functions

In addition to using backup and restore for business continuity purposes,
you can use this feature as a time-saving mechanism. For instance, you
can quickly provide access from another Dominion device to your team
by backing up the user configuration settings from the device in use and
restoring those configurations to the new Dominion device.
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Backup and Restore (Dominion KX Il only)

» To backup the entire system (both user and device

configuration):

1. Choose Tools > Backup All. The Backup All dialog appears.

T
~| =/ 8=l

Save in: ||j My Docurnents

-0-0-1-4936,p

Ld
=
=
ra

Y BUOZ0907.p

3 evtlog.txt

_jl JavaConsole. txt

L
=
=
R

-0-0-1-4242,fp

L
-
s
o

-0-0-1-4%49,+vp

_jl JavaConsole2 txt |j| KoK=

ha

-0-0-1-4290,Hp

-0-0-1-5006,Hp

Ld
=
=
ra

_j JavaConzole3 txt

Y K#-2-0-0-0-5146.fp [ ) K¥-2-0-0-1-5038.rfp

)

[ kx-2
[ kx-2
[ ku-2
[ kx-2
[ kx-2
[ kx-2

-0-0-1-50435,fp
-0-0-1-307 7. fp
-0-0-1-5094,fp
-0-0-2-5122,vp

-0-0-2-5129,fp

-0-0-2-5135.fp

File name:  [MPCO315.fp

Files of tvpe: | RFP Files (*.Hp]

Sauve || [Cancel |

2. Navigate to the desired directory and give the backup file a name.

(Backup files have an extension of .rfp).

3. Click Save. A message is displayed confirming the successful

backup.
4. Click OK.
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Note: Backups are always complete system backups. Restores can be
complete or partial depending on your selection.

> To restore:

1. Choose Tools > Restore Configuration. The Restore Device

Configuration dialog appears.

Restore Device Configuration B

Lock in: ||j My Docurnents

=l fialfi=]

x|

5]

a.p
0.Hp
2.fp
0.+
1.+p

4.+fp

A

File narne:

Files of tvpe: | RFP Files (*.Hp]

[ kx-2z-0-
[ kx-z-0-
[ kx-z-0-

0-2-5265.rfp
0-2-5274.rfp
0-2-5279.tfp

[ ke-2-0-0-2-5324.fp [ U-BOOT-18-22.1fp

[ kx-2-0-0-2-5333.fp

[ ki-2-0-0-2-5343.p

[ kx-2-0-0-2-5282.fp [ ) K¥-2-0-0-2-5351.p
[ kx-2-0-0-2-5288.p i—D MPCOZ15. rp
[ kx-z-0-0-2-5310.fp [ ) Tast.rfp
R |}|
[MPcOz1s. R

Qpen || Cancel |

P WD

Navigate to the appropriate directory and select the backup file.

Click Open. The Restore Packages dialog appears.

Select the type of restore you want to run:

Full Restore: A complete restore of the entire system; generally used
for traditional backup and restore purposes.

Protected Restore: Everything is restored except device-specific
information such as serial number, MAC Address, IP Address, name,
port names, etc. With this option, you can setup one Dominion
device and copy the configuration to multiple Dominion devices.

Custom Restore: The following options are available:

User and Group Restore: This option includes only user and
group information. Use this option to quickly setup users on a
different Dominion device. This option restores the certificate and
the private key file that were currently active when the backup

occurred.
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= Device Settings Restore: This option includes only device
settings such as power associations, USB profiles, blade chassis
related configuration parameters, and Port Group assignments.
Use this option to quickly copy the device information.

Click OK.

Backing Up and Restoring a Device Configuration

>

To back up a device:

Download the device configuration to your local computer by
selecting the device in the Navigator.

Click Tools > Save Device Configuration.

To restore a device configuration:

Upload the archived device configuration by selecting the device in
the Navigator.

Click Tools > Restore Device Configuration.

Note that device configuration is specific to a particular device and
should not be restored to another device.

Backing Up and Restoring a User Configuration

>

2.

To back up a device's user configuration:
Select the device in the Navigator.

Click Tools > Save User Configuration.

To restore a user configuration:

Upload a device's archived user configuration by selecting the device
in the Navigator.

Click Tools > Restore User Configuration.

Note: Use these commands to easily transfer user and group information
from one device to another.

Log Files

Activity Log

>

1.

To download a detailed activity log for review or
troubleshooting:

Select the device in the Navigator.
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2. Onthe Tools menu, choose Save Activity Log.

Diagnostic Log (excluding 1)

» To download a detailed diagnostic log for reporting or analysis:
1. Select the device in the Navigator.

2. Onthe Tools menu, choose Save Diagnostic Log.

Broadcast Port

By default, all Raritan devices send data through Port 5000. This network
traffic includes the autodiscovery broadcast. In the case of conflicts or to
deal with firewall issues, you may want to use a different broadcast port.

MPC Broadcast Port

» To change the autodiscovery port from the default broadcast
port of 5000:

Select the device in the Navigator.
Choose Tools > Options. The Options dialog appears.

3. Onthe Advanced tab, type the new port number in the Port field of
the Broadcast Port section and then click OK.
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Note: If you want the application to autodiscover Raritan devices on the
new broadcast port you entered in the Options dialog, you must
configure all Raritan devices to use the new port number.

O'ptians [g|
General Advanced |

KWM Switch ©3UI Hot Key

@ 3croll Lock + Scrall Lock
() Murn Lock + Hurm Lock

O Caps Lock + Caps Lock

Broadcast Port

Port [S000

IPvE Metworking

I:‘ Enable IPYE Metworking

Logging

D Enable Logging

| DK || Cancel || Apply |

RRC Broadcast Port

» To change the autodiscovery port from the default broadcast
port of 5000:

1. Select the device in the Navigator.
2. On the Tools menu, choose Options. The Options dialog appears.

3. Inthe Broadcast Port field, type the new port number in the Port field
and then click OK.
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Note: If you want the application to autodiscover Raritan devices on the
new broadcast port you entered in the Options window, you must
configure all Raritan devices to use the new port number.

Options &]

General ]

[ Skow scroll barders.
v ALbo-Spac mouse in bwo curscr moce,
¢ Dizplay single Curzo mude iresaucions,
[ Acko-Color Calibration,

FAbe Switzly OSUL ot Kew

¢ Gemll Losk + Seroll Lack
" Mum Lock + Mum Lock
" Caps Lock + Caps Lock

F.euboard Shorlcut b enu Hotlkey
Haotkew |Ctl + &k + v =

Broadcasz: Part

Part |B00C

- Logging
[~ Enmable Logging

0, Cancel

If you do not want to use the broadcasting function at all, it can be turned
off.

> To turn off broadcasting:
1. InRRC, select View > Show.

2. Deselect the Discovered Devices checkbox.
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Broadcasting will be turned off and the devices will not be displayed
in the navigator.

Connection USE Profile Zerial Keyboard Wideo Mousze Vidual Media Tools |Wiew Window Help

il

Epal [z @ ==0me e

¥ Standard Toalbar
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¥ Connected Server(s] Toolbar
¥ Status Bar

¥l Nauigataor

¥ Message

Show M ¥ Dizcovered Davices
Sart ]

[J Unassigned Channels

Target Screen Resolution M Tools

[0 Scale wideo |

Remote Power Management

AC power to associated targets can be managed when used with a
properly configured Raritan Remote Power Control Strip (RPC strip).
Three options are available when performing remote target power
management:

e Power On
e Power Off
e Cycle Power

» To change the power status of a target:
1. Select the device in the Navigator.

2. On the Tools menu, choose Power On, Power Off, or Cycle Power.

Import/Export Keyboard Macro Definitions

The functions contained in this section describe how to exchange
keyboard macro definitions between users using import and export
functions. The primary purpose of this function is to exchange data
between copies of the client application.

Import/Export MPC Keyboard Macros

» To import MPC macros:

Choose Tools > Import Macros to open the Import Macros dialog. By
default, the macro will exist on the desktop.

2. Click on the macro file and click Open to import the macro.

a. If too many macros are found in the file, an error message will be
displayed and the import will terminate once OK is selected.

b. If the import fails, an error dialog will appear and will display a
message regarding why the import failed. Select OK to continue
the import without importing the macros that cannot be imported.

137



Chapter 3: Multi-Platform Client and Raritan Remote Client

138

Select the macros to be imported by checking their corresponding
checkbox or using the Select All or Deselect All options.

Click OK and the import will begin.

a.

If a duplicate macro is found, the Import Macros dialog will
appear. Do one of the following:

Click Yes to replace the existing macro with the imported
version.

Click Yes to All to replace the currently selected and any
other duplicate macros that are found.

Click No to keep the original macro and proceed to the next
macro

Click No to All keep the original macro and proceed to the
next macro. Any other duplicates that are found will be
skipped as well.

Click Cancel to stop the import.

Alternatively, click Rename to rename the macro and import
it. If Rename is selected, the Rename Macro dialog will
appear. Enter a new name for the macro in the field and click
OK. The dialog will close and the process will proceed. If the
name that is entered is a duplicate of a macro, an alert will
appear and you will be required to enter another name for
the macro.

If during the import process the number of allowed, imported
macros is exceeded, a dialog will appear. Click OK to attempt to
continue importing macros or click Cancel to stop the import
process.
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The macros will then be imported. If a macro is imported that contains a
hot key that already exists, the hot key for the imported macro will be
discarded.

» To export MPC macros:

1. Choose Tools > Export Macros to open the Select Keyboard Macros
to Export dialog.

Select Keyboard Macros to Export E'
Minirmize All wWindaows | calac All
2l
| Ceszelact All
| Ok | | Cancel |

2. Select the macros to be exported by checking their corresponding
checkbox or using the Select All or Deselect All options.

3. Click OK. The selected macro file(s) will be moved to your desktop
(by default).

A dialog from which you can locate and select the macro file will then
appear. By default, the macro will exist on your desktop.
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4. Locate the macro file, click it to select it and then click Save. If the
macro already exists, you will receive an alert message. Select Yes
to overwrite the existing macro or No to close the alert without
overwriting the macro.

- Export Keyboard Macros to

Save in: ||j Dasktop LVJ @ I__‘E[‘_| @ EElE

|j My Dacurnents
|j My Cormputear

3 my Hetwork Flaces
[ ovs Folders

File narme: |

Files of type: |><ML Files (*,=ml) -

Save | | Cancel |

Import/Export RRC Keyboard Macros

> To export RRC macros:
1. Choose Tools > Export Macros to open the Export Macros dialog.

-

Raritan Remote Client Export Macros

[wlAlPrintScreen

Cancel

Select All

Unselect all

[=smT]
==

2. Select the macros to be exported by checking their corresponding
checkbox or using the Select All or Unselect All options.

3. Click OK. The selected macro file(s) will be moved to your desktop
(by default).

A select dialog from which you can locate and select the macro file
will then appear. By default, the macro will exist on your desktop.
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4. Locate the macro file, click on it to select it and then click Save. If the
macro already exists, you will receive an alert message. Select Yes

to overwrite the existing macro or No to close the alert without
overwriting the macro.

Raritan Remote Client Export Macros

Save in: l@ Desktop

> -_2 My Docurments
3 My Computer

by Recent ‘QMV Metwork Places
Documents |#] keyboardMacros.kbm
Deskiop

My Network  File name: IKQ}lhoaTdMa_E:ros.kBm
Places

Cancel

Q | Save
|

i

Save as type: | Raritan K.epboard Macros [* kbm)

> To import RRC macros:

1. Choose Tools > Import Macros to open the Import Macros dialog. By

default, the macro will exist on the desktop.

Raritan Remote Client Import Macros

Look in: l@ Desklop j
Lé [E:]My Documents
52 My Computer

My Fecent &My Netwark Places
Documents m keyboardMacros. kbm
Deskiop

My Documents

My Computer

-

My Netwark.  File name: IKeyboardM acros.kbm j Open I
Places
Files of type: IHaritan Keyboard Macros [*kbm) j Cancel |

2. Click on the macro file and click Open to import the macro.

=& Raritan.
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a. If too many macros are found in the file, an error message will be
displayed and the import will terminate once OK is selected.

. = ™ |

Raritan Remote Client Import Macros

" "_n,, You cannat impark more than 32 kevboard macros,
L

b. If the import fails, an error dialog will open and will display a
message regarding why the import failed. Select OK to continue
the import without importing the macros that cannot be imported.

Raritan Remote Client Import Macros .

® The Following macros contain unsupporked

infomation and will not be imported.

Zancel |
Bad Data

3. Select the macros to be imported by checking their corresponding
checkbox or using the Select All or Unselect All options.

4. Click OK and the import will begin.

Raritan Remote Client Import Macros "

[w]AltPFink Screen

Cancel

Select All

Unselect Al

[“emt
=
[mes]

a. If a duplicate macro is found, a dialog will appear. Do one of the
following:
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= Click Yes to replace the existing macro with the imported
version.

= Click Yes to All to replace the currently selected and any
other duplicate macros that are found.

= Click No to keep the original macro and proceed to the next
macro

= Click No to All keep the original macro and proceed to the
next macro. Any other duplicates that are found will be
skipped as well.

= Click Cancel to stop the import.

F.

Raritan Remote Chient Import Macros

The Following macro already exisks;
aaaa

Would wou like to replace the macro?

Yes to Al Mo Mo To Al Rename

Cancel

= Alternatively, click Rename to rename the macro and import
it. If Rename is selected, Raritan Remote Client Rename
Macro dialog will open. Enter a new name for the macro in
the field and click OK. The dialog will close and the process
will proceed. If the name that is entered is a duplicate of a
macro, an alert will appear and you will be required to enter
another name for the macro.

= =}

"F_!aritan Femote Client Rename Macro E

Ik I Cancel |
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b. If during the import process the number of allowed, imported
macros is exceeded, a message will appear. Click OK to
attempt to continue importing macros or click Cancel to stop the
import process.

Raritan Remote Client Import Macros .

" "-'.‘ The maximum number of macros (32) has already been reached.
.}

i Cancel |

The macros will then be imported. If a macro is imported that
contains a hot key that already exists, the hot key for the imported
macro will be discarded.
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Accessing the MPC Diagnostic Interface (excluding 1)

» To access adevice's diagnostic console:

¢ In the Navigator, scroll through the list of the targets associated with
the device and then double-click the Diagnostic icon at the bottom of
the target list.

Raritan Multi-Platform Clien

Connection  WEE Profile  Serial Kavb Tools window Help 3

1 1 R o Y e
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Overview

i

Raritan.

Virtual media extends KVM capabilities by enabling KVM target servers
to remotely access media from a client PC and network file servers. With
this feature, media mounted on a client PC and network file servers is
essentially "mounted virtually" by the target server. The target server can
then read from and written to that media as if it were physically
connected to the target server itself.

Virtual media can include internal and USB-mounted CD and DVD
drives, USB mass storage devices, PC hard drives, and ISO images
(disk images).

Note: ISO9660 is the standard supported by Raritan. However, other ISO
standards can be used.

Virtual media provides the ability to perform additional tasks remotely,
such as:

e Transferring files

e Running diagnostics

e Installing or patching applications

e Complete installation of the operating system

This expanded KVM control eliminates most trips to the data center,
saving time and money, thereby making virtual media very powerful.
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Diagram key

@ Desktop PC
@ CIM
@ Target server

CD/DVD drive

USB mass storage device

PC hard drive

Remote file server (ISO
images)
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Prerequisites for Using Virtual Media

With the virtual media feature, you can mount up to two drives (of
different types) that are supported by the USB profile currently applied to
the target. These drives are accessible for the duration of the KVM

session.

For example, you can mount a specific CD-ROM, use it, and then
disconnect it when you are done. The CD-ROM virtual media “channel”
will remain open, however, so that you can virtually mount another
CD-ROM. These virtual media “channels” remain open until the KVM
session is closed as long as the USB profile supports it.

The following conditions must be met in order to use virtual media:

e For users requiring access to virtual media, the device permissions
must be set to allow access to the relevant ports, as well as virtual
media access (VM Access port permission) for those ports. Port

permissions are set at the group-level.

e A USB connection must exist between the device and the target

Server.

e If you want to use PC-Share, Security Settings must also be enabled

in the Security Settings page. Optional

e You must choose the correct USB profile for the KVM target server

you are connecting to.

Client PC

e Certain virtual media options require administrative privileges on the
client PC (for example, drive redirection of complete drives).

Note: If you are using Microsoft Vista, turn User Account Control off:
Control Panel > User Accounts > User Account Control > turn off.
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If you would prefer not to change Vista account permissions, run
Internet Explorer as an administrator. To do this, click the Start
Menu, locate IE, right-click it and select Run as Administrator.

Target Server
e KVM target servers must support USB connected drives.

e KVM target servers running Windows 2000 must have all of the
recent patches installed.

e USB 2.0 ports are both faster and preferred.

» To use virtual media:

e Connect/attach the media to the client or network file server that you
want to access from the target server. This need not be the first step,
but it must be done prior to attempting to access this media.

File Server Setup (File Server ISO Images Only)

Note: This feature is only required when using virtual media to access file
server 1ISO images.

1ISO9660 format is the standard supported by Raritan. However, other
CD-ROM extensions may also work.

Use the Remote Console File Server Setup page to designate the files
server(s) and image paths that you want to access using virtual media.
File server ISO image(s) specified here will become available for
selection in the Remote Server ISO Image Hostname and Image
drop-down lists in the Map Virtual Media CD/ISO Image dialog. See
CD-ROM/DVD-ROM/ISO Images (on page 154).

> To designate file server ISO images for virtual media access:

Choose Virtual Media from the Remote Console. The File Server
Setup page opens.

2. Check the Selected checkbox for all media that you want accessible
as virtual media.

3. Enter information about the file server ISO images that you want to
access:

= |P Address/Host Name - Host name or IP address of the file
server.

= Image Path - Full path name of the location of the ISO image.

Note: The host name cannot exceed 232 characters in length.

150 Y=

=i=Raritan.



Chapter 4: Virtual Media

4. Click Save. All media specified here will now be available for
selection in the Map Virtual Media CD/ISO Image dialog.

Homa = Fila Sarvar Satup Lagout

File Server Setup

IPv4 Address-Host Name: Enter mame of the host name or IF Address of shared drive containing ".iso” image.
Image Path: Enter path to ".iso” image on shared drive. Do not include host name or iP Address in the path.

Selected Host NamePAddress Image: Path
O

O

oo

ogo|io

olo

E

Save | | Cancel |

Using Virtual Media

With the virtual media feature, you can mount up to two drives (of
different types) that are supported by the USB profile currently applied to
the target. These drives are accessible for the duration of the KVM
session.

For example, you can mount a specific CD-ROM, use it, and then
disconnect it when you are done. The CD-ROM virtual media “channel”
will remain open, however, so that you can virtually mount another
CD-ROM. These virtual media “channels” remain open until the KVM
session is closed as long as the USB profile supports it.

e The following conditions must be met in order to use virtual media:

e You must choose the correct USB profile for the KVM target server
you are connecting to.

Client PC

e Certain virtual media options require administrative privileges on the
client PC (for example, drive redirection of complete drives).

Note: If you are using Microsoft Vista, turn User Account Control off:
Control Panel > User Accounts > User Account Control > turn off.

If you would prefer not to change Vista account permissions, run
Internet Explorer as an administrator. To do this, click the Start
Menu, locate IE, right-click it and select Run as Administrator.
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Target Server
e KVM target servers must support USB connected drives.

e KVM target servers running Windows 2000 must have all of the
recent patches installed.

e USB 2.0 ports are both faster and preferred..

1. If you plan to access file server ISO images, identify those file
servers and images through the Remote Console File Server Setup
page. See File Server Setup (File Server ISO Images Only).

Note: ISO9660 format is the standard supported by Raritan.
However, other CD-ROM extensions may also work.

2. Open a KVM session with the appropriate target server.
a. Open the Port Access page from the Remote Console.
b. Connect to the target server from the Port Access page:
= Click the Port Name for the appropriate server.

= Choose the Connect command from the Port Action menu. The
target server opens in a Virtual KVM Client window.

3. Connect to the virtual media.

For: Select this VM option:

Local drives Local Drives (on page 153)
Local CD/DVD drives CD-ROM/DVD-ROM/ISO Images
ISO Images Connect CD-ROM/ISO Image
File Server ISO Images Connect CD-ROM/ISO Image

Upon completion of your tasks, disconnect the virtual media. See
Disconnecting Virtual Media (on page 156).
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Connecting to Virtual Media

i

Raritan.

Local Drives

This option mounts an entire drive, which means the entire disk drive is
mounted virtually onto the target server. Use this option for hard drives
and external drives only. It does not include network drives, CD-ROM, or
DVD-ROM drives. This is the only option for which Read/Write is
available.

Note: KVM target servers running certain versions of the Windows
operating system may not accept new mass storage connections after an
NTFS-formatted partition (for example, the local C drive) has been
redirected to them.

If this occurs, close the Remote Console and reconnect before
redirecting another virtual media device. If other users are connected to
the same target server, they must also close their connections to the
target server.

> To access adrive on the client computer:

1. From the Virtual KVM Client, choose Virtual Media > Connect Drive.
The Map Virtual Media Drive dialog appears.

Map Virtual Media Drive: DominionKXIl Port 1 |z|

Select a local drive for mounting onto the target server.
Local Drive :

: (Hard Disk) 4 |

Cnnnecti Cancel i

2. Choose the drive from the Local Drive drop-down list.

3. If you want Read and Write capabilities, select the Read-Write
checkbox. This option is disabled for nonremovable drives. See the
Conditions when Read/Write is Not Available (on page 154) for
more information. When checked, you will be able to read or write to
the connected USB disk.

WARNING: Enabling Read/Write access can be dangerous!
Simultaneous access to the same drive from more than one entity
can result in data corruption. If you do not require Write access,
leave this option unselected.
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4. Click Connect. The media will be mounted on the target server
virtually. You can access the media just like any other drive.

Conditions when Read/Write is Not Available
Virtual media Read/Write is not available in the following situations:
e For all hard drives.
e When the drive is write-protected.
e When the user does not have Read/Write permission:
= Port Permission Access is set to None or View.

= Port Permission VM Access is set to Read-Only or Deny.

CD-ROM/DVD-ROM/ISO Images
This option mounts CD-ROM, DVD-ROM, and ISO images.

Note: ISO9660 format is the standard supported by Raritan. However,
other CD-ROM extensions may also work.

» To access a CD-ROM, DVD-ROM, or ISO image:

1. From the Virtual KVM Client, choose Virtual Media > Connect
CD-ROM/ISO Image. The Map Virtual Media CD/ISO Image dialog
appears.

*Map Wirtiual Media CD TS0 Image: LPmachine - EI
Select a COUDVD drive or an 150 inmage 1o moamt onto the L gel server.

= [Local COTWD Drive]
|C: (CD-ROM) |

150 Image:
Image Path:

" Remaote Server 130 Image
Hoztname: g
File Server Usemarmea: File Server Password:

Connect | Cancel |

2. Forinternal and external CD-ROM or DVD-ROM drives:
a. Choose the Local CD/DVD Drive option.

=i=Raritan.
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b. Choose the drive from the Local CD/DVD Drive drop-down list.
All available internal and external CD and DVD drive names will
be populated in the drop-down list.

c. Click Connect.
3. For ISO images:

a. Choose the ISO Image option. Use this option when you want to
access a disk image of a CD, DVD, or hard drive. ISO format is
the only format supported.

b. Click the Browse button.

c. Navigate to the path containing the disk image you want to use
and click Open. The path is populated in the Image Path field.

d. Click Connect.
4. Forremote ISO images on a file server:
a. Choose the Remote Server ISO Image option.

b. Choose Hostname and Image from the drop-down lists. The file
servers and image paths available are those that you configured
using the File Server Setup page. Only items you configured
using the File Server Setup page will be in the drop-down list.
See for more information.

c. File Server Username - User name required for access to the file
server.

d. File Server Password - Password required for access to the file
server (field is masked as you type).

e. Click Connect.

The media will be mounted on the target server virtually. You can
access the media just like any other drive.

Note: If you are working with files on a Linux target, use the Linux Sync
command after the files are copied using virtual media in order to view
the copied files. Files may not appear until a sync is performed.

Note: You cannot access a remote 1ISO image via virtual media using an
IPv6 address due to technical limitations of third-party software used by
the KX2.
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Disconnecting Virtual Media

» To disconnect the virtual media drives:
e For local drives, choose Virtual Media > Disconnect Drive.

e For CD-ROM, DVD-ROM, and ISO images, choose Virtual Media >
Disconnect CD-ROM/ISO Image.

Note: In addition to disconnecting the virtual media using the Disconnect
command, simply closing the KVM connection closes the virtual media
as well.

156
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Raritan Serial Console

The standalone Raritan Serial Console (RSC) is used to make direct
connections to a serial target without going through the device. The user
specifies the device address and the port number (target), and is then
connected.

In This Chapter

RSC System ReQUIFEMENTS. ....cuiiieiiiiiiiieieee e e e eeiiieee e e e e e s ssinrreeneee e e 157
Installing RSC 0N WINAOWS .......cooiiiiiiiiiiieeiieeee e 162
Installing RSC for Sun Solaris and LinUX ..........ccooveiiiiiiienniiieeieen, 164
Opening RSC from a  Remote COoNSOle..........cceeeiiiiiieiiiiiiie e 165
Raritan Serial Console INterface ...........cccceeeiiiiiiiiiieieee e 167

RSC System Requirements

The following requirements must be met to support the Raritan Serial
Console:

e The RSC will function with JRE version 1.4.2_05 or later (except for
JRE version 1.5.0_02). However, for optimum performance,
Raritan recommends using JRE 1.5.0 (except for version 1.5.0_02).

e Your system may require configuration adjustments depending on
the operating system and browser. The JRE provides configuration
instructions with the JRE download. Browse to the page at
http://www.java.com/en/download/help/testvm.xml
(http://www.java.com/en/download/help/testvm.xml \o
http://www.java.com/en/download/help/testvm.xml) to determine the
JRE version currently installed on your system. If you do not have a
compatible version of the JRE, go to http://www.java.com
(http://www.java.com) and click the Download Now button.

Note: Raritan does not support JRE version 1.5.0_02 for use with the
RSC.

e Minimum 1 GHz PC with 512 MB RAM.

Ensure that Java can be started from the command line. To do this,
environment variables must be configured. Make a note of the exact path
where Java was installed. (The path information will be used later.)

IMPORTANT: When launching RSC from a browser, Raritan highly
recommends that Java Applet Caching be disabled and that you
perform the following steps to make sure that Java does not create
problems for the system's memory.
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Setting Windows OS Variables
1. Choose Start > Control Panel > System.
2. Click the Advanced tab and then click Environment Variables.

System Properties

3. Inthe System variables section, click New.
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4. In the New System Variable dialog, add JAVA_HOME to the Variable
name block and the path you wrote down earlier in the Variable
value block.

New System Variable

unaz!cmd,m
4

C\WINDOWS\system3Z;C: \WINDOWS; .. _ﬂ

Click OK.
Select the PATH variable and click Edit.

Add %JAVA_HOME%\bin to the end of the current Variable value.
Ensure a semicolon (;) separates the new value from the last value
in the string.
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8. Click OK.

Edit Systenn Yariable

PROCESSOR_ID... x86 Family 15 Model 3 Stepping 4, Genu...
PROCESSOR_LE... 15 |

9. Select the CLASSPATH variable and click Edit.

10. Ensure the CLASSPATH Variable value is configured properly; that
is, its value must have a period (.) in it. If, for any reason, there is no
CLASSPATH variable defined, create one.

I
i Edit System ¥ariahle
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Setting Linux OS Variables

To set Java for a specific user, open and edit the .profile file located in
the /home/Username folder.

To set Java for all users, open the .profile file in your /etc folder:

1. Find the line where you set your path:

export
PATH=$PATH:/home/username/somefolder

2. Before that line you must set your JAVA_HOME and then modify
your PATH to include it by adding the following lines:

export
JAVA HOME=/home/username/j2sdkl.4.2/
export PATH=$PATH:$JAVA HOME/bin

3. Save the file.

Setting UNIX OS Variables
To check the latest JRE version on Sun Solaris:
1. Launch aterminal window on the Sun Solaris desktop.

2. Type java -version in the command line and press Enter. The
currently-installed version of Java Runtime Environment (JRE)
appears.

= If your path variable is not set to where the Java binaries have
been installed, you may not be able to see the JRE version.

= Assuming JRE 1.4.2_05 is installed in /usr/local/java: you must
set your PATH variable.

= To set a path for the bash shell:

export
PATH=$PATH:/usr/local/java/j2rel.4.2_05/bin

= To set path for tcsh or csh:

set
PATH = ($PATH /usr/local/java/j2rel.4.2_05/bin)
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= These commands can either be typed at the terminal each time
you log in, or you can add them to your .bashrc for bash shell or
.cshrc for csh and tcsh so that each time you log in, the path is
already set. See your shell documentation if you encounter
problems.

Window Edit Options Help

# java -version

java version "1.4.2_05"

Jaya(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_05-b04)
Java HotSpot(TM) Client VM (build 1.4.2_05-b04, mixed mode)

#

3. Ifthe JRE is version 1.4.2_05 or later, proceed with the RSC
installation. If the JRE is version 1.5.0 02 or is an older version
than 1.4.2_05, go to the Sun website at
(http://java.sun.com/products/) to download the latest Runtime
Environment.

Installing RSC on Windows

You must have administrative privileges to install RSC.

> To install RSC on Windows:
Log on to a Windows machine.

2. Download, or copy from a known location, the RSC-installer.jar
installation file.

3. Double-click the executable file to start the installer program. The
splash page appears.

Click Next. The installation path page appears.
Change the path, if desired.

Click Next. The installation progress page appears.
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Note: The standalone version of Raritan Serial Console (RSC) is
available from the Raritan website (www.raritan.com) on the Support

page.

of IzPack - Installation of Raritan Serial Console

&9 Pack installation progress:
ﬁ Crverall inskallstion progress:

171

(Made with TzPack - http: ey izf orge. com))

@revous || Qe || Gor |
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7. Click Next. The Windows shortcut page appears.

oF IzPack - Installation of Raritan Serial Consale

Select a Program Group For the Shortouts:

Accesgonss A

Admiristrative Tooks

Aucdobe

America Oriine crasbe dhorbout Foi
Cison Systams YPN Chank ) currerk user
CWENT e

Doedl Accessonies @ bl serd
Dredl Wirsderss

Games

Google Deskiop o

Raritan Serial Consols Reset

C-rud:c shartcut on the dl:sk!np

(Made wath [zfack - hitp: [T izf onge. com

L Oprevius || Onext || Gow |

8. Specify the desired Program Group for the shortcut.
9. Click Next. The installation finished page appears.
10. Click Done.

Installing RSC for Sun Solaris and Linux

You must have administrative privileges to install RSC.
1. Log into your Sun Solaris machine.

2. Download, or copy from a known location, the RSC-installer.jar
installation file.

3. Open a terminal window and change to the directory where the
installer is saved.

Type java -jar RSC-installer.jar and press Enter to run the installer.

Click Next after the initial page loads. The Set Installation Path page
opens.

a. Select the directory where you want to install RSC and click
Next.

b. Click Browse to navigate to a non-default directory.
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c. Click Next when the installation is complete.

d. Click Next again. The installation is complete. The final page
indicates where you will find an uninstaller program and provides
the option to generate an automatic installation script.

6. Click Done to close the Installation dialog.

Opening RSC from a Remote Console

=i=Raritan.

» To open the Raritan Serial Console (RSC) from the Remote
Console:

1. Select the Port Access tab.

4

Port Access !
Click on the individual port name to see allowable operations. ;
0 of 1 Remote KVIM channels currently in use.

4 Port Humber Port Hame Port Type Status Availabil

1 Wiin Target Wl up iclle

2 Drominion_KSX2_Port2 Mot &y ailable dowvn iclle

iEL Drorminion_HKSX2_Port3 Mot Levailable diowvn iclle

4 KEH-G2 Ldmin Wi up iclle

5; Drotmimion_HKSX2_Ports Mot Lyailable closvn iclle :

E Dotnimion_KSX2_PorE Mot Ay ailzble closvn idlle {

7 Dominion_KSX2_Port? Mot &y ailable dowvn iclle

g Dominion_KSX2_Portd kot Axyailable dowvn iclle 1

9 Cizco 2501 Serial up iclle

10 Sp-2 Setial up iclle

11 Serial Port 3 Serial up iclle {

12 Serial Port 4 Serial up iclle

13 N SP-3 Serial up iclle F

14 l’\§ Serial Port 6 Serial Lp iclle: 4

15 Serial Port 7 Serial up icle

16 Serial Port 5 Serial up icle
i b e A A sk A P P e A b At

2. Click the name of the serial port you want to access for the RSC.
Note: A security pop-up screen appears only if you used https to
connect to the RSC.
3. If you're using Dominion DSX:
= Click Yes. A Warning - Security pop-up screen appears.
= Click Yes to access the Raritan Serial Console from the Port
page.

Note: If you click Always, you will not receive the security page for

future access.

= The Raritan Serial Console window appears.
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If you're using Dominion KSX or KX:

= Click Connect to start connecting to the target port for RSC, and
the Raritan Serial Console window appears.

= The Raritan Serial Console window appears.

Note: You can download the standalone Raritan Serial Console from the
Raritan website (www.raritan.com) on the Support page.

P  To open RSC from the Windows desktop:

Double-click the shortcut or use the Start menu to open the
standalone RSC. The Raritan Serial Console Login connection
properties window appears.

2. Enter the device's IP address, account information, and the desired
target (port).

3. Click Start. RSC opens with a connection to the port.

Note: If you experience unrecognized characters or blurry pages in the
RSC window due to localization support, try changing the font to Courier
New. Click Emulator > Settings > Display and select Courier New for
Terminal Font Properties or GUI Font Properties.

Note: When RSC connects to a serial target, hitting Ctrl + _ or Ctrl + ~ +
_ does not cause information to be sent. However, hitting the Ctrl + Shift
+ _or the Ctrl + Shift + ~ will cause information to be sent.

» To open RSC on Sun Solaris:

Open a terminal window and change to the directory where you
installed the RSC.

Type ./start.sh and press Enter to open RSC.
Double-click the desired device to establish a connection.
Type your user name and password.

Click OK to log on.

ok DN
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Raritan Serial Console Interface

Important: The Raritan Serial Console page usually opens in a
separate window behind the Port page. With some versions of Java
on Windows, the page opens in front of the Port page.

E Raritan Serial Console: Sexial Port 7 (15)

Emulator Edit Tools Chat Help

1. 5EZ:E000/LE" please walt ...

[ Write Access  Code Set: UTF-8  Logoing: off  Users: 1

Default RSC Option Values

The following default values apply to the GUI font properties, colors and
fonts defined in RSC:

Item Value
Font properties Lucida Console

GUI font properties Lucida Console

Colors Black foreground and white
background

A/
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Emulator

1. Change the default user Idle Timeout setting before launching the
RSC for the first time or it will timeout in 10 minutes and display a
host termination message.

2. Click the Emulator drop-down menu to display a list of topics.

Rarnitan Serial Console: Senal Port 7 {15)

Emulator Edit Tools Chat Help

Settings. ..

et History l -El.5Z:5000/1%' please wait ... il

Clear History

et Write Lock

Send Break
Connected Users...

Exit

[ Write Access Code Set: UTF-8 Logoying: off Users: 1
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Settings

1. Choose Emulator > Settings. The Settings page displays the General
tab with the default settings.

Sethings: Serial Fort 1 {9)

[f General f Display

GUI Interface

Main Menu Shortcut: Show Confirmation Dialog on Exit

Hone -

Terminal Compatibility
Terminal Size: History Buffer Size:

80 % 25 e 200}{

Backspace Sends:

ASCH DEL -

Cursor type
@ Block Cursor

i Line cursor

0k Cancel Default

2. Accept the Main Menu Shortcut default of None or choose one of the
following from the Main Menu Shortcut drop-down menu:

= F10
= Alt
Accept the Show Confirmation Dialog on Exit default or uncheck it.

4. Accept the Terminal Size default or choose a size from the Terminal
Size drop-down menu.

5. Accept the Backspace Sends default of ASCIlI DEL or choose
Control-H from the Backspace Sends drop-down menu.

6. Accept the History Buffer Size default of 75 or use the arrows to
change the buffer size.
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7. Accept the Cursor type default of Block Cursor or select Line Cursor.
8. Click OK.

Display Settings

1. Choose Emulator > Settings, and then click the Display tab.

Sethings: Serial Fort 7 {15)

Goneras | Dispiay |

Font Directories

(L]

l/TErITIiII.al Font Properties rGIJI Font Properties

|ru1|:|nnspaced
Monospaced i
NSIimSun Font size:
Raavi il 11 3
Shruti =
SimHei -
Colors Locale

Encoding:
Foreground: Background: |UTF-3 | - |

~ | | conguese

|Emjlish |v|

Preview-

Font Prewiew

Ok Cancel Default

2. Click Default to accept the Default settings. Then click Ok to close

the Display Settings dialog. However, if you want to change the
settings, perform the following steps:

3. Accept the Terminal Font Properties default of Lucida Console or
choose a font from the scrolling list of Terminal Font Properties.

4. If you want to change the size of the font, choose a font size by
clicking the up or down arrows. The result of selected font and font
size is displayed in the Preview box.

= -
—
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5. Click the GUI Font Properties tab and accept the default of Lucida
Console or choose a font from the scrolling list of GUI Font
Properties.

Settings: Serial Poxt 7 (15) [$_<|

Font Directories

]

rTBI‘]TIIi_llal Font Properties |/GI.II Font Properties

|ru1|:| nospaced
Monospaced =
NSIimSun
Raawvi |
Shruti =
SimHei =
Colors- Locale
Encoding:
Foreground: Background: ||_|TF_3 | - |
- w || | Language :
|English | . 8 |
Preview-

Ok Cancel Default

Note: For Simplified Chinese characters, Raritan Serial Console
supports EUC-CN encoding system.

6. Choose the following from their drop-down menus:
= Foreground Color
= Background Color
7. Choose one of the following from the Encoding drop-down menu:
= US-ASCII
* |S0O-8859-1
* |S0O-8859-15
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UTF-8
Shift-JIS
EUC-JP
EUC-CN
EUC-KR

Choose one of the following from the Language drop-down menu:

English
Bulgarian
Japanese
Korean

Chinese

Click Ok to close the Display Settings dialog. If you changed the
Language setting, the RSC changes to that language when the

Display Settings dialog is closed.
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Note: If you experience unrecognized characters or blurry pages in the
RSC window due to localization support, try changing the font to Courier
New.

Get History

History information can be useful when debugging, troubleshooting, or
administering a target device. The Get History feature allows you to view
the recent history of console sessions by displaying the console
messages to and from the target device.

When the size limit is reached, the text will wrap, overwriting the oldest
data with the newest.

Note: The history data is displayed only to the user who requested the
history.

e To view the session history, choose Emulator > Get History.

Clear History
e To clear the history, choose Emulator > Clear History.
Get Write Access

Only administrators and operators can get Write access. The user with
Write access can send commands to the target device. Write access can
be transferred among users working in the Raritan Serial Console via the
Get Write Access command.

To enable Write access, choose Emulator > Write Access.
e You now have Write access to the target device.
e When another user assumes Write access from you,

= The RSC displays a red block before Write access in the status
bar.

= A message alerting the user who currently has Write access
appears to tell that user that another user has taken over access
to the console.
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Get Write Lock

e Choose Emulator > Get Write Lock. If the Get Write Lock is not
available, a request rejected message appears.

Write Unlock
e Choose Emulator > Write Unlock.
Send Break

Some target systems, such as Sun Solaris servers, require the
transmission of a null character (break) to generate the OK prompt. This
is equivalent to issuing a STOP-A from the Sun keyboard.

e Only users with Administrator privileges can send a break.
e Users who are Operator or Observers cannot send a break.

» To send an intentional break to a Sun Solaris server:

1. Verify that you have Write access. If not, follow the instructions in the
previous section to obtain Write access.

2. Choose Emulator > Send Break. A Send Break Ack
(Acknowledgement) pop-up appears.

3. Click OK.
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The Connected Users command allows you to view a list of other users
who are currently connected on the same port.

1. Choose Emulator > Connected Users, a Connected Users page is

displayed.

% Connected Osers: Serial Fort 1 (9) |Z|

Tzer Name

WMrite Access

admin

2. A check mark appears in the Write access column after the name of
the user who has Write access to the console.

3. Click Close to close the Connected Users window.

Exit

1. Choose Emulator > Exit to close the Raritan Serial Console. The Exit

Confirmation page appears.
2. Click Yes.
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Edit

Use the Copy, Paste, and Select All text commands to relocate and/or
re-use important text.

E Raritan Serial Console: Serial Port 7 (15)

Emulator Ed:l.t | Tools Chat Help

! |
| Copy

l Paste F.165.61_52: 5000415

please wait ...

| Select All

[ Write Access Code Set: UTF-8  Loguging: off  Users: 1

To copy and paste all text:

Choose Edit > Select All.

Choose Edit > Copy.

Position the cursor at the location where you want to paste the text.

Click once to make that location active.

o~ N =Y

Choose Edit > Paste.

e ==Raritan.
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Note: The copy-paste limit of text in Raritan Serial Console is 9999 lines.

Keyboard shortcuts that you can use to highlight, copy, and paste all or
partial lines of text:

e Click and drag your mouse over the text you wish to copy.
e Use Ctrl+C to copy text.

e Position the cursor where you want to paste the text and click in that
location to make it active.

e Use Ctrl+V to paste text.

Tools

Click the Tools menu to display a list of topics.

arnitan Seral Console: Seral Foxt 7 (15)

Emulator Edit |[Tools Chat Help
& b‘d Start Logging

-

= 5000715 please wait ...
Send Keystroke
SEend Text File
Togyle Power

[ Write Access Code Set: UTF-8 Logoying: off Users: 1
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Start Logging

The Start Logging function allows you to collect raw console data from
the target device and save it to a file on your computer. When you start
RSC, the Logging indicator on the status bar indicates whether logging is

on or off.

1. Choose Tools > Start Logging.

2. Choose an existing file or provide a new file name in the Save RSC
Log dialog.

= When an existing file is selected for logging, data gets appended
to the contents.

= |f you provide a new file name, a new file is created.

% Save REC Log

Save In: | My Documents - |:| E
File Name: | |
Files of Type: |Lng Files | - |

| Save | | Cancel |

3. Click Save after selecting or creating a file.
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Stop Logging
Choose Tools > Stop Logging. The logging stops.

Send Keystroke

1. Choose Tools > Send Keystroke. A Send Keystroke dialog appears:

Send KeyStroke: Serial Port 1 {(9) |E|

Eeystroke combination:
Mare

[Jctrl [ ]Alt [ |Shift

Eey code:
None -
Send Clear Cancel

2. Enter the keystroke combinations that you want and select a Key
Code name from the drop-down menu.

3. Send the keystroke combinations.

Send Text File

1. Choose Tools > Send Text File. A Send Text File screen appears.
Open the directory of the Text file.

2
3. Click on or enter the File Name of the Text file.
4

Click Open.
= When you click Open, it sends whatever file you selected directly
to the port.

= If there is a loopback plug inserted, you will see the file displayed.

= If there is currently no target connected, then nothing will be
visible on the screen.
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Toggle Power

The Toggle Power function lets you power on or off the device that is
connected to the associated outlet on a Power Distribution Unit (PDU).
For example, if a router is connected to one of the outlets on the PDU,
you can toggle the router’'s power on or off.

You must configure the association of outlets to the target port of the
device before you can use the Toggle Power feature. Go to the Power
Control tab on remote console's GUI to configure the outlets. If you have
not done this, the system displays a message stating that the target is
not associated with a power outlet.

Note: If RSC is launched through CC-SG (version 4.x onwards) by users
without the permission to toggle power, the option Toggle Power will
appear as disabled.

1. Select Toggle Power to turn the device (router) on or off. A prompt
appears displaying the current status of the outlet(s). You can turn
the device on or off depending on its current status.

If you select No, the system returns you to the RSC screen.

3. Ifyou select Yes, the system sends the power command to either
turn on or off the outlets associated to the target port of the device.

If you receive a:
e Hardware error message: this means that the PDU command failed.

Software error message: this means that another user is controlling the
power outlet and the power control command cannot be sent.
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Chat

When using browser access over SSL, an interactive chat feature called
Chat allows you and other users on the same port to communicate. You
can conduct an online dialog for training or collaborative diagnostic
activities. The maximum length of a chat message is 300 characters.

Note: When a chat is initiated, a chat window appears on the monitors of
all SSL users logged on to the port. If a user is logged into a port multiple
times, multiple chat messages will not appear to that user.

> To open chat:
e Choose Chat > Chat.

E5 Chat: Serial Port 1 {9)

1]

Hessaige : Remaining: 300

[ b

1]

| Send H Clear H Close

> To clear text in a chat text box:
e Click Clear to delete the typed text.

i
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Help

Help Topics include online assistance for operating the Raritan Serial
Console and release information about Raritan Serial Console.

Help Topics

P To access help topics:
e Choose Help > Help Topics.

About Raritan Serial Console

The About Raritan Serial Console dialog displays the copyright and
version information (name and revision number) of the console terminal
emulation software. When contacting Raritan for technical support or
when performing a software upgrade, you may be asked for this
information.

» To access 'About' information:

e Choose Help > About Raritan Serial Console. An About Raritan
Serial Console message appears.
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> U.S./Canada/Latin America

Monday - Friday

8am.-8p.m. ET

Phone: 800-724-8090 or 732-764-8886

For CommandCenter NOC: Press 6, then Press 1

For CommandCenter Secure Gateway: Press 6, then Press 2
Fax: 732-764-8887

Email for CommandCenter NOC: tech-ccnoc@raritan.com
Email for all other products: tech@raritan.com

» China

Beijing

Monday - Friday

9 a.m. - 6 p.m. local time
Phone: +86-10-88091890

Shanghai

Monday - Friday

9 a.m. - 6 p.m. local time
Phone: +86-21-5425-2499

GuangZhou

Monday - Friday

9 a.m. - 6 p.m. local time
Phone: +86-20-8755-5561

> India

Monday - Friday
9 a.m. - 6 p.m. local time
Phone: +91-124-410-7881

P Japan

Monday - Friday

9:30 a.m. - 5:30 p.m. local time
Phone: +81-3-3523-5994

Email: support.japan@raritan.com

» Europe

Eu rope

Monday - Friday

8:30 a.m. -5 p.m. GMT+1 CET
Phone: +31-10-2844040

Email: tech.europe@raritan.com

United Kingdom
Monday - Friday

8:30 a.m. to 5 p.m. GMT
Phone +44(0)20-7090-1390

France

Monday - Friday

8:30 a.m. -5 p.m. GMT+1 CET
Phone: +33-1-47-56-20-39

Germany

Monday - Friday

8:30 a.m. - 5:30 p.m. GMT+1 CET
Phone: +49-20-17-47-98-0
Email: rg-support@raritan.com

» Melbourne, Australia

Monday - Friday
9:00 a.m. - 6 p.m. local time
Phone: +61-3-9866-6887

> Taiwan

Monday - Friday

9 a.m. - 6 p.m. GMT -5 Standard -4 Daylight
Phone: +886-2-8919-1333

Email: support.apac@raritan.com
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